Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Some calls (inbound and outbound) do not have audio (always one way)

Discussion in '3CX Phone System - General' started by John Ranger, Oct 18, 2017.

Thread Status:
Not open for further replies.
  1. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    Hi all,

    lately I am observing that some of the calls (either inbound or Outbound) do not have Audio in one of the directions (it affects always only one of the two directions - sometimes I cannot hear the Person which is outside of our PBX (e.g. on PSTN) - in that case they can hear me ---- or they cannot hear me but I can hear them.

    If then the call gets hanged up (either by me or by them) and I or they redial then the Audio works again in both directions.

    The Problem always immediately goes away when redialed after a call where Audio has failed in one direction.

    Our 3CX Pbx Connects to the outside "phone world" via a Switzerland-Sipcall-based Voip Trunk.

    Hint: When we had V14, this Problem was not there but started after I migrated to V15.

    Any hints to how to start Troubleshooting this?

    Thanks and with Kind regards,

    John
     
  2. narkumas

    narkumas New Member

    Joined:
    Nov 28, 2016
    Messages:
    227
    Likes Received:
    29
    What kind of firewall do You have? Are You using SIP ALG?
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,380
    Likes Received:
    535
    Hello @John Ranger

    Did you run the firewall checker of the PBX located on the dashboard of the management console? Were the tests successful?
     
  4. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    Hi Narkumas,
    we have a DrayTek VDSL router (Vigor 2850). So far this router has worked very well together with the 3CX System (using this combination already for several years).

    I remember that I turned off SIP ALG when I first installed the 3CX when we bought that router (3-4 years ago).

    But I have turned it off now again (don't know how to check on the router if it was already off or not).

    With Kind regards,

    John
     
    #4 John Ranger, Oct 18, 2017
    Last edited: Oct 18, 2017
  5. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    Hi YannisH,

    I am currently running it but this takes over 6h to complete as the test of each of the ports takes about 3/4 of a Minute --> Therefore I have suggested today under "new ideas" to parallelize this scan.

    I will Report what the Outcome is of this... Tomorrow...

    With Kind regards,

    John
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,380
    Likes Received:
    535
    Please note that the test should not take that long. When i run it it takes ~2 minutes to complete the whole test. That would suggest that there is indeed an issue with your firewall.
     
  7. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    Hi Yannis,

    thanks for your Feedback. Good to know...

    With the FW tester in 3CX V12 this was much faster - but now this is slow. Nevertheless all 182 ports so far tested are done with a "green done" so it seems to basically work which means that the Basic FW config seems to be correct.

    The router/Firewall so far has worked great - also ist Speed is ok for us. The only Thing which takes Long over this Firewall seems to be the FW checker from 3CX :)

    I will "sniff" the traffic to the 3CX during such a FW checker test in order that I can see if there are some retries or so.

    Anything which you could add from your experience?

    Thanks and with Kind regards,

    John
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,380
    Likes Received:
    535
    I would be a good idea running a capture side by side with the firewall checker to see what might be wrong. I would also check your machines resources in case there is an issue there. I h ave never seen a firewall checker test take this long
     
  9. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    Hi YannisH,
    the resources of the machine should not be the Problem: It is a VM running as the only VM on a recent quad core (8 thread) Xeon processor with 32 GB RAM on a Hyper-V-Server. The VM itself has 24GB RAM assigned.

    The physical CPU load on the machine is about 3-5%, inside the VM it is about 15-20%.

    The VM feels blazing fast when working via RDP on it.

    Did not yet managed to take a Network traffic capture and have to re-run the port check as we needed the phonesystem yesterday again.

    Will Keep you updated here what the FW checker has to say.

    John
     
  10. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    So: Made the full Firewall check run and all passed without any Problems altough it took a Long time.

    Interestingly since I did the SIP_ALG_OFF (again) and the Firewall checker run, no "one way audio" Problems have occured since.

    Either the force of the SIP_ALG_OFF or the restart of the 3CX Services (e.g. media_Service) has helped.

    I will observe this - and if it occurs again - then I will first restart the 3CX media Service.

    --> If this helps then I will schedule a periodic restart of the 3CX media Service once a day in the early morning.

    Thanks everybody for your help. I will post an update here if this occurs again and I implement some counter-measures.

    With Kind regards,

    John
     
  11. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,380
    Likes Received:
    535
    Hello John and thank you for the feedback. Please keep an eye on the issue and let us know if anything changes.
     
Thread Status:
Not open for further replies.