Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Someone has tested SPA400 on 3CX?

Discussion in '3CX Phone System - General' started by netmatika, Mar 12, 2007.

Thread Status:
Not open for further replies.
  1. netmatika

    Feb 16, 2007
    Likes Received:
    Hi all,
    someone has tested SPA400 on 3CX with or without SPA9000?


  2. Costas3CX

    Costas3CX New Member

    Jan 23, 2007
    Likes Received:
    As far as the 3CX testing team is concerned, we haven't tested against this hardware. However we would be very interested to hear anyone testing with this and hear their results.
  3. Anonymous

    Anonymous Guest

    I know that it can be done (I think, I hope :D ) because people have configured the SPA400 with the Asterisk & CommunigatePro PBX software.

    Here's the link:


    Any clues on how to setup the authentication between 3CX and SPA400? It seems as though that is the only thing that is causing the SPA400 and 3CX not to register.

  4. Anonymous

    Anonymous Guest

    Are you using a SPA9000 in combination?

    From 3cx point of view every fxo port can be seen as a gateway.

    Having said that your user ID will be the line ID (eg 10001) and your password is what you setup in the line management.

    THat should work in theory, you might have to setup dial plans (to rout to the 3cx box).

    If you point me to an admin manual for sure we can figure it out.

  5. Anonymous

    Anonymous Guest

    Thanks for the quick reply.

    Yes I am currently using the SPA9000 as my IP PBX but I would like to switch over to the 3CX instead. My Linksys IP Phones register with the 3CX without any problems but I am having difficulty, as I mentioned earlier, in getting my SPA400 gateway to register.

    The problem or confusion for me is that the authentication for the PSTN lines in my SPA400 is not clear in terms of how it relates to the 3CX PBX.

    I put up the following web page that has screen shot of my current SPA400 configuration as well as a link to the admin guide in PDF format.


    Hopefully this has the information that you need.

    Just so I understand correctly:

    By Line ID you mean the 'Internal Number' as listed on the line management page?

    And my password reffers to any password that is assigned to the line in my SPA400 configuration pages?

    Thanks again for the assistance.

  6. Anonymous

    Anonymous Guest

    Hmm might work, problem is the password but if you leave that blank in 3cx it might work.


    Use STATIC IP = this will be the IP address of the 3cx box.
    SIP Settings: SIP Port = 5060 (3cx Port)
    Subscriber Information: User ID = 10000 (Same as in the line configuration ID)
    Use for the voice codecs G711 (either one will do).

    Only problem is the password, I do not see where to enter that but leave it blank in 3cx and it might work.

    My understanding is that although there are 4 lines in, it only advertises one (SPA9000 only sees it as one line). I guess you have to do the same with 3cx, also you cannot configure a SIP port per line either. So I am not sure how to go about that as yet.

    If you get it going you might let us know what the log shows re incomming call eg. does it show. FXO_Port_ID1 etc. You migth be able to put the Line ID from 3cx in there I do not know without testing it. (not having a spa400 myself :))
  7. Anonymous

    Anonymous Guest

    Well I'm running out of luck I think. I've tried various combinations of settings, nothing seems to work. It is defiantely a credentials thing. Here is the log:

    08:40:20.609 StunClient::process STUN resolved external IP= by server
    08:20:20.328 StunClient::process STUN resolved external IP= by server
    08:19:37.765 AuthMgr::eek:nAuthFailure Registration request from sip:anonymous@localhost failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    08:19:37.765 AuthMgr::requestCredential Message SipReq: INVITE 10000@ tid=-3d7b3ee4-be49b-418f905b cseq=INVITE contact=FXO_Port_ID_1@ / 2 from(wire) failed authentication!
    08:19:37.765 AuthMgr::requestCredential Authentication ID for Ln:10002@spa400 doesn't match provided:  vs 10000
    08:19:10.453 Endpoint::findSource Unrecognizable source. More than one line corresponds received INVITE

    Maybe some clarification of terms/items could help me a bit.

    In My SPA400:

    User ID: What does this relate to with respect to my 3CX Config
    Port ID: What does this relate to with respect to my 3CX Config
    Since there is no password field, I should leave blank in 3CX? Is this what you were reffering to in previous post?

    In My 3CX

    Internal Number: Value comes from SPA400?
    External Number: Value comes from SPA400?
    Authentication ID: Value comes from SPA400?
    Authentication Password: Value comes from SPA400?

    I appreciate all the help. Thanks again.

  8. Anonymous

    Anonymous Guest

    User ID realates to the authentication ID in 3cx, you set this up when you create a new line that is connected to the gateway/provider you created.

    Port ID is the SIP number again you configure this when you setup a gateway or provider.
    FXO_Port_ID, looks like that is used as an ID aswell, put in there the same number you have in the USER ID. 10000

    Ill have a closer look when I get back in the office, but this might help you on your way.

  9. Anonymous

    Anonymous Guest

    OK Henk, now it is starting to makes sense.

    UserID(SPA400) = AuthenticationID(3CX)
    PortID(SPA400) = Internal Number(3CX)
    Pasword(3CX) = Blank - Since there is no password field in the SPA400

    With that being said, as long as the port ID's are unique, such as 10000 & 10001 & 10002 etc..., 3CX should be able to recognize the individual FXO ports that way and I imagine then that the SPA400 is just using the same userID for all 4 ports without a password.

    Unfortunately though it is still not registering the PSTN lines. I have not seen any errors in the log for quite some time also. How do you manually force a registration of the PSTN lines. Restart the 3CX services?

    LINKSYS has really made this a difficult box to work with!!!!!

  10. Anonymous

    Anonymous Guest

    :lol: We are pretty much on our own here I guess. Nobody has gone here before, but tha makes it fun :).

    Perhaps we can do something with the advanced options, but I do not know much about them (as yet). The Gateway got some intersting options all the way at the bottom Require (optionally: authorized) registration for: I have no idea what they do really, but what will happen if you select Nothing (doesn't require registration at all) would that work?

    You might not be to worried about the lights going green in the line status area, as long as you can receive calls? I think we got the mapping of the user ID etc correct it is now only the authorisation to make 3cx happy.

    I was thinking...... can you try to set the SPA400 up as a provider instead of a gateway? But again not sure if that will work or actually will do anything.

    Have you tried to make an inbound call and see if it is "popping up" in 3cx?

    To their credit I do not think we using the device where it originally was designed for. It was designed to provide more FXO port for the SPA9000 was it not?
    But than again that should not stop us :twisted:

    Question for the 3cx guys:
    Can we trick 3cx in not needing a PWD etc. To be honest it is a bit "limiting" to have password requirements for gateways. Would be nice if we could do that without authentication to bind the line to the gateway that is.

    Hope this helps.
  11. Anonymous

    Anonymous Guest

    Yes this is fun isn't it. You're right with your statement about Linksys designing this specifiaclly for their IP PBX only, but I also think it should definately work with other PBX's.

    You bring up an interesting point about not requring registration. By the way, how do you manually force a registration in 3CX?

    I set these two values in the gateway properties.:
    Require (optionally: authorized) registration for: Nothing
    Use registration's 'Contact' field host/port instead host/port specified in configuration: both checked and unchecked
    I also set Line-ID matching: to Internal Number

    Here are the results when I call in: (Line Always Stays Red And Status Unregistered)
    09:30:39.828 Endpoint::findSource Can not find source by following specs: From: 'anonymous'; To: '10000'; Rline: 'spa400'; Contact: '10000'

    What does this mean?

  12. Anonymous

    Anonymous Guest

    Oops do not like the looks of that, I think we need a dial plan (something that tells the SPA where to route the call too). Unless we can tell it where to go.......

    I am out of my comford zone here, but it is good to see that 3cx is aware of the device (hence the message) we need to figure out now how to bind the port to the extension. I have to make some test calls, but cannot do that now (everybody is sleeping here atm its almost midnight :)). So i have to do that tomorrow.

    Have a play by adding in the ports something like (I am just making educated guesses here).

    UserID(SPA400) = 10000@[IP address of your 3cx box]:5060
    PortID(SPA400) = 10000@[IP address of your 3cx box]:5060
    UserID(SPA400) = 10000@[IP address of your 3cx box]:5060
    PortID(SPA400) = 10000@[IP address of your 3cx box]:5060

    Bit of trial and error cannot hurt :). What i am hoping for is that it knows the Line ID(being 10000) it knows it own IP and it needs to listen to port 5060.

    Lets see how we go with that.

  13. Anonymous

    Anonymous Guest


    Might actually shed some light on our situation :). I have not read it but it looks like it is allong the lines we try to solve (based upon you error messages).

    Oops should have used edit :?
  14. Anonymous

    Anonymous Guest

    It's Finally Working!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Thank you for your absolutely awesome assistance on this problem. I am going to post screenshots of my config for others to use.

    In short:
    Line-ID mATCHING --> Internal Number
    Line ID Location --> To Field
    Require Registration --> Nothing
    Use registration's 'Contact' field host/port instead host/port specified in configuration --> Unchecked

    The lines show up as unregistered but the communication is still functional. Here is what the logs show when an incomming call arives:

    15:45:34.578 CallLegImpl::eek:nConnected Established media channel for Ln:10000@spa400: remote=; local=
    15:45:34.546 CallConf::eek:nIncoming Incoming call from Ln:10000@spa400 to sip:10000@

    Thanks again for all your help!!!! Much appreciated.

  15. Anonymous

    Anonymous Guest

    :lol: :lol: :D :p

    Is all I can say

    Oh :idea: would fit aswell.


  16. carlo_isap

    Apr 1, 2007
    Likes Received:
    Hi Guys,

    Can I ask for the settings of this one? I also have a problem connecting from spa400 to 3cx as gateway.

    thanks in advance
  17. Anonymous

    Anonymous Guest

    Re: Hi Guys,

    Sure, No problem.

    I have posted the screenshots of all the necessary pages that need to be configured on both the SPA4000 and 3CX. Just keep these couple things in mind. Configure all of the 4 FXO ports even if you are not using all of them and turn off registration of the FXO ports. If you do that and mimick all of my setting, it should work.

    Are you using the Linksys SPA942 phones as well? If so, let me know if you get message waiting lights to work.

    Here's the link:

  18. Anonymous

    Anonymous Guest

    Perhaps a little much to ask but I am keen to see some of your 3cX screen shots.

    Especially your line management and gateway configs for those lines you use with the SPA400.

    How are you log files?

  19. Anonymous

    Anonymous Guest

    No problem at all.

    What screen shots in particular are looking for? I'll post them to my website just like my other screen shots.


  20. nanees

    Mar 28, 2007
    Likes Received:
    Incoming Calls

    Hi Brian,

    First off thanks for the setup help so far and posting this information .

    I configured my gateway (SPA400) 192.168.104 using the setting you posted from you screenshots:

    I can get outgoing calls to work just fine , however , I get no incoming calls . I dont know its a problem on the SPA400 end of the 3CX.

    In a nutshell, i've configured the Gateway and Line Settings to exactly mirror yours in 3CX , the same goes for the SPA400. I changed all the FXO port Id's to match the internal numbers on my 3CX line.

    Line 1 Internal Number = 10000
    FXO Port ID_1 = 10000

    You mentioned something about disabling the registration for the FXO Ports, is this done in the SPA400 ? I already disabled registration for the gateway setup in 3CX.

    Here is the log when I make an outgoing call:
    11:35:38.906 StratLink::eek:nHangUp Call(C:9): got Hang-Up from Ext.120; reason: BYE
    11:35:24.812 CallLegImpl::eek:nConnected Established media channel for Ln:10000@SPA400: remote=; local=
    11:35:24.796 StratInOut::eek:nConnected Call from Ext.120 to Ln:10000@SPA400 is established
    11:35:24.796 CallLegImpl::eek:nConnected Established media channel for Ext.120: remote=; local=
    11:35:21.500 CallConf::eek:nIncoming Incoming call from Ext.120 to sip:94952499@

    Incoming Call: For some reason I get no log in 3Cx for any incoming call.

    Any help is appreciated, my email is Nanees@LibertyTax.com , if you have one as well I can send you my config screenshots
    Thanks !
Thread Status:
Not open for further replies.