SonyEricsson Xperia Arc: No sound in speaker

Discussion in 'Android' started by jesfab, Feb 10, 2012.

Thread Status:
Not open for further replies.
  1. jesfab

    Joined:
    Nov 17, 2011
    Messages:
    4
    Likes Received:
    0
    I have no speaker sound in 3CXPhone for Android version 1.3.4 on my SonyEricsson Xperia Arc. Even if the other part puts the call on hold there’s no sound (no MOH).

    I use the Android together with 3CXPhone for Windows (version 6.0) and 3CX Phone System version 10 running in Windows XP SP3.

    The sound works fine in the opposite direction (i.e., from Android to Windows).

    The situation is the same wherever the call is initiated.

    The Xperia runs Android version 2.3.4.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    Do you mean the earpiece?

    Are you using this over WiFi or 3G? Have you tried it over WiFi on the same LAN as your PBX installation?

    What about when you receive a call? Any audio?

    Have you gone over the 3CX log for the call, anything show an error or problem?
     
  3. jesfab

    Joined:
    Nov 17, 2011
    Messages:
    4
    Likes Received:
    0
    Yes.

    WiFi.

    It's the same wherever I receive the call or I place the call from the Android.

    Here is the log. The Android has ext. 14.

    11:26:42.858 [CM503008]: Call(56): Call is terminated
    11:26:34.907 [CM503007]: Call(56): Device joined: sip:12@10.20.1.39:2207;line=7eb7423065d394f9
    11:26:34.907 [CM503007]: Call(56): Device joined: sip:14@192.168.1.2:46838;ob
    11:26:34.897 [CM505001]: Ext.12: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Ninja GlobalIPTel 4.8 Build 16889] PBX contact: [sip:12@10.20.1.49:5060]
    11:26:34.897 [CM503002]: Call(56): Alerting sip:12@10.20.1.39:2207;line=7eb7423065d394f9
    11:26:30.851 Currently active calls - 1: [56]
    11:26:29.339 [CM503025]: Call(56): Calling Ext:Ext.12@[Dev:sip:12@10.20.1.39:2207;line=7eb7423065d394f9]
    11:26:29.309 [CM503004]: Call(56): Route 1: Ext:Ext.12@[Dev:sip:12@10.20.1.39:2207;line=7eb7423065d394f9]
    11:26:29.309 [CM503010]: Making route(s) to <sip:12@10.20.1.49:5060>
    11:26:29.309 [CM505001]: Ext.14: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXPhone for Android 1.3.4] PBX contact: [sip:14@10.20.1.49:5060]
    11:26:29.299 [CM503001]: Call(56): Incoming call from Ext.14 to <sip:12@10.20.1.49:5060>
    11:26:17.401 [CM504001]: Ext.14: new contact is registered. Contact(s): [sip:14@192.168.1.2:46838;ob/14]

    /Jesper
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    So IP 10.20.1.49 is that of your 3CX server, you local LAN is 10.20.XX.XX, correct?

    The IP of Ext 14 (the Android) is 192.168.1.2, with port 46838, correct?

    I'm going to assume that the Android is behind another router. If that is the case then it should be registering with the public IP of that router (and it's local port number) , not a private IP, which it is doing now.

    Check to be sure that STUN is set-up properly, on the Android, and that you are using the "I am out of the office" setting.
     
  5. jewel86

    Joined:
    Feb 27, 2012
    Messages:
    1
    Likes Received:
    0
    Other ideals ? I tried, but it's not' ok :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jesfab

    Joined:
    Nov 17, 2011
    Messages:
    4
    Likes Received:
    0
    Yes.

    Yes.

    I cannot register my Android on a public IP address, it requires changes in our network configuration. Unfortunately! :(

    STUN Server is set to stun3.3cx.com.
    I have tried with "I am out of office" checked and unchecked. But the result is the same.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    If the Android phone continues to register using a private IP, (that is the IP that 3CX will use to try to reach the phone), then it will continue to fail.

    If you cannot make changes to your network to allow this, then it sounds like you are out of luck.
     
  8. jesfab

    Joined:
    Nov 17, 2011
    Messages:
    4
    Likes Received:
    0
    I have no problem with registering. And (as I wrote earlier) it goes fine making calls, picking up calls, put calls on hold, etc. My only problem is the missing sound in the Android's earpiece.
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    Sorry, I thought you were experiencing no sound of any kind. If it's just getting the sound in the earpiece, but you do get sound from some other "device" (bluetooth, speaker, etc.) then it would seem to indicate some sort of incompatibility issue between the 3CX phone App and your particular set.
     
Thread Status:
Not open for further replies.