Sound problem

Discussion in 'Windows' started by islander, Jan 20, 2009.

Thread Status:
Not open for further replies.
  1. islander

    Joined:
    Jan 15, 2009
    Messages:
    7
    Likes Received:
    0
    When using soft phone (3.0.4959.0) connected from outside of firewall with tunnel there is no sound getting trough from soft phone to the other party.
    Firewall problem?
    Tunnel ends at 127.0.0.1 ?

    3cx Installed Version:7.0.4249.0 running on SBS 2008 its working fine otherwise with provider cellip ( lokal provider BIKAB not working yet as seen in log)

    Port 5090 is forwarded to the PBX on 192.168.222.2
    Firewall is DD-WRT v24sp1



    09:03:07.126 [CM503008]: Call(35): Call is terminated

    09:02:56.687 [CM503007]: Call(35): Device joined: sip:46441234555@sip.mysecretary.net:5060

    09:02:56.685 [CM503007]: Call(35): Device joined: sip:14@127.0.0.1:52706;rinstance=aa2498efc38d1a48

    09:02:56.682 [CM505003]: Provider:[Cellip] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] Transport: [sip:192.168.222.2:5060]

    09:02:56.680 [CM503002]: Call(35): Alerting sip:46441234555@sip.mysecretary.net:5060

    09:02:42.897 [CM503016]: Call(35): Target is not registered: VoIPline:04458650 dialed on (AnyLine@bikab)

    09:02:42.897 [CM303003]: There are no available outbound lines on gateway bikab at this time.

    09:02:42.888 [CM503004]: Call(35): Calling: VoIPline:04458650@(Ln.10000@Cellip)@[Dev:sip:46441234555@sip.mysecretary.net:5060]

    09:02:42.881 [CM503010]: Making route(s) to <sip:04458650@192.168.222.2:5060>

    09:02:42.880 [CM505001]: Ext.14: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXVoipPhone 3.0.4959.0] Transport: [sip:192.168.222.2:5060]

    09:02:42.877 [CM503001]: Call(35): Incoming call from Ext.14 to <sip:04458650@192.168.222.2:5060>
     
  2. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Have you run the firewall checker on the 3CX machine

    Try to put in the internal IP of the 3CX machine, not the localhost IP of 127.0.0.1 in the softphone settings

    You could also try the new softphone
    http://www.3cx.com/forums/new-3cx-softphone-beta-with-integrated-tunnel-8562.html#p43888
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. islander

    Joined:
    Jan 15, 2009
    Messages:
    7
    Likes Received:
    0
    I Have run the firewall check, updated to latest 3cx release (7.0.4744), I have tested the softphone on 3 different computers both the first and the latest beta, and as i turned out I didn't work even when running locally without the tunnel.
    No outgoing sound from softphone in any case, so it's not the firewall to wan, I then turned of the firewall on the server that didn't help.

    127.0.0.1 Where should i use this?
    When it says local ip of PBX i put in the local IP in my case 192.168.222.2, and in the soft phone window it says 14@192.168.222.2 !?
    Is this where I'm doing it the wrong way?

    Attempting to connect xx.xxx.155.124
    Using network interface 127.0.0.1
    Attempting to start the tunnel
    Tunnel got as listening port 49979
    Tunnel got as local SIP port 49980
    Tunnel listening port OK
    Tunnel connection created OK
    Tunnel started
    Phone requested as local port 5070
    Phone requested local port OK
    Tunnel is attempting to connect remote end
    Tunnel connection established
    RTP engine OK
    SIP engine OK
    Sound mic device OK
    Sound ring device OK
    Sound play device OK
    Tunnel send from phone to PBX: REGISTER
    Tunnel received from PBX status 407
    Tunnel send from phone to PBX: REGISTER
    Tunnel received from PBX status 200
    Phone online status is now 'Available'
    Phone is now connected
    Tunnel send from phone to PBX: INVITE
    Tunnel RTP ports OK
    Tunnel received from PBX status 407
    Tunnel send from phone to PBX: INVITE
    Tunnel RTP ports OK
    Tunnel received from PBX status 404
    Tunnel send from phone to PBX: INVITE
    Tunnel RTP ports OK
    Tunnel received from PBX status 407
    Tunnel send from phone to PBX: INVITE
    Tunnel RTP ports OK
    Tunnel received from PBX status 486
    Destination is busy
    Tunnel received from PBX to phone: INVITE
    Tunnel offers SDP
    Tunnel RTP ports OK
    Tunnel send from phone to PBX status 180
    Tunnel send from phone to PBX status 200
    Tunnel received from PBX to phone: ACK
    Tunnel received from PBX to phone: BYE
    Tunnel send from phone to PBX status 200
     
  4. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Is there a single network card in the SBS server with a single IP?
    If the client does not work on the LAN without the tunnel then you have a configuration/networking/firewall issue. I would disable the firewall on the SBS server and test internally to get things working before trying from external.

    Can you also set the 3CX logging to verbose to give you more information in the logs.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Sorry for not asking earlier - the headset you are using has been tested any you are certain that you are getting audio out of it?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. islander

    Joined:
    Jan 15, 2009
    Messages:
    7
    Likes Received:
    0
    Tested on different computers with different hardware so it's not likely that all would be wrong..

    There are only one network connection active/enabled, IPV6 is also used.

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Virtual Machine Bus Network Adapter
    Physical Address. . . . . . . . . : 00-15-5D-DE-34-0C
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::15b:f659:1e8a:c062%10(Preferred)
    Link-local IPv6 Address . . . . . : fe80::10f6:6749:c4ce:538f%10(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.222.2(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.222.100
    DNS Servers . . . . . . . . . . . : fe80::10f6:6749:c4ce:538f%10
    192.168.222.2
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 8:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{2DBB4514-B114-4B81-A3EE-72B8E4FC7
    BD2}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 11:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
     
  7. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,503
    Likes Received:
    69
    Hi, Islander

    From the 3CXPhone's side, according to this log fragment everything seems perfectly OK - somebody called 3CX, tunnel "prepared" audio, 3CX ringing, 3CX answering, audio connection established, then (later) caller hungup. But, as you said, the caller does not receive audio coming from 3CXPhone.

    May looks amusing, but it's a serious question revealing a possible trap: on your 3CXPhone, you configured it to work on a specific audio device (for microphone I mean)? Because, in this case, you should be careful, it might happen hmmm... to speak on the wrong microphone, or the microphone for that audio device be muted or to a low recording level :mrgreen:

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. islander

    Joined:
    Jan 15, 2009
    Messages:
    7
    Likes Received:
    0
    When I have some time I will install 3cx on another machine and verify that everything works there.
     
  9. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,503
    Likes Received:
    69
    Hi, Islander

    Before this, you still may try to do something on actual configuration, to split the "100%" problem into two "50%" 8).

    At this moment the call's "channel" is phone1-PBX-phone2, and you have no audio coming from phone1. So, let's try to remove phone2 from ecuation:

    - do a call from phone1 to phone2, but when phone 2 rang, instead of picking up the call, divert it to voicemail. Therefore, the phone1 will be forced to provide audio to the PBX's recording engine.
    - Record a message
    - Then, from phone2, read the voicemail and check if something has been recorded.

    So, when you have time, please do this test and check if the recorded wav is silent or not.

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. islander

    Joined:
    Jan 15, 2009
    Messages:
    7
    Likes Received:
    0
    Sorted out two of the computers, one that used a USB headset that was working fine with skype for some reason the level was set to low when using soft phone cranking up the level to max solved the problem, another (old) laptop with built in microphone, turns out the microphone is dead on it :oops:

    On the third I don't know the story yet since it's located on the other side of the world, this one was the one i wanted the tunnel on.

    One other question why is the softphone sending out dialcodes when starting up, it try to dial to *60 on all outgoing lines, is this normal?
     
  11. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,503
    Likes Received:
    69
    Hi, Islander

    Don't be :oops: at least you're not alone, since I "enjoyed" myself such "surprises" provided by soundcards :mrgreen: :lol:

    About dialcodes, this "feature" is already removed from the in-development version of the Voip Phone and, therefore, will no longer be available in the next release.
    The *60 and *61 dialcodes are, by default, commands to instruct 3CX PBX to mark the phone as available/away. But, there are two critical problems:
    - these dialcodes are 3CX-specific, therefore should not be hardcoded into the phone;
    - while they are hardcoded into the phone, their semantics can be changed by the PBX's admin.

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.