Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Source ID Problem which could not be solved

Discussion in '3CX Phone System - General' started by macher, Mar 31, 2008.

Thread Status:
Not open for further replies.
  1. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    HI,

    we have installed the software and outbound works well.
    But Inbounded just without the extensions.
    I have checked the part from the http://www.3cx.com/support/source-id-errors.html
    But this did not help because 018903642200 is the main number 018903642 plus extention 200
    WOuld I need to do this for every extention?
    This I thing wouldn´t make a sense.

    Your help is appretiated - thanks


    [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:018903642200@85.126.13.154:5060;rinstance=035e9f46a90a9e71 SIP/2.0
    Via: SIP/2.0/UDP 212.41.253.181;branch=z9hG4bK1997.80752825.0
    Via: SIP/2.0/UDP 172.29.183.11;rport=5060;branch=z9hG4bK1997.3c622557.0
    Via: SIP/2.0/UDP 172.29.183.103:5062;branch=z9hG4bK7b5cd19aa
    Max-Forwards: 69
    Record-Route: [sip:212.41.253.181;r2=on;lr=on;ftag=deb5771a5389633]
    Record-Route: [sip:172.29.183.10;r2=on;lr=on;ftag=deb5771a5389633]
    Record-Route: [sip:172.29.183.11;lr=on;ftag=deb5771a5389633]
    Contact: [sip:0676840374300@172.29.183.103:5062]
    To: [sip:018903642200@p1.voip.inode.at]
    From: [sip:0676840374300@p9.voip.inode.at];tag=deb5771a5389633
    Call-ID: db488ad8f667360b7ba87497ee569e23@p9.voip.inode.at
    CSeq: 441193280 INVITE
    Session-Expires: 600
    Supported: timer, replaces
    User-Agent: Patton SN2400 MxSF v3.2.8.45 00A0BA020B1D R3.21 2007-09-14_RFE10808 H323 SIP
    P-Preferred-Identity: [sip:0676840374300@172.29.183.103]
    Content-Length: 0

    Thanks in Advance,
    Ernst
     
  2. Powermage

    Powermage New Member

    Joined:
    Mar 19, 2008
    Messages:
    103
    Likes Received:
    0
    Add an DID number with that caller id and route it to an extension/que/group
     
  3. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    HI, I have tried this -

    I have added the following DID:

    DID Name: Test 200
    DID/MSN/Mask: 018903642200
    Override incoming Caller ID with DID name: Selected

    Anywhere

    Connect to Extension: 200

    And I still get the following Error Message in the Server Status

    [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:018903642200@172.29.183.103:5060;rinstance=6c1a1652e42bdc79 SIP/2.0
    Via: SIP/2.0/UDP 212.41.253.181;branch=z9hG4bK279f.ad903e17.0
    Via: SIP/2.0/UDP 172.29.183.7;rport=5060;branch=z9hG4bK279f.921fc1a2.0
    Via: SIP/2.0/UDP 172.29.183.102:5062;branch=z9hG4bK48deadcb7
    Max-Forwards: 69
    Record-Route: [sip:212.41.253.181;r2=on;lr=on;ftag=156009dabfd12b0]
    Record-Route: [sip:172.29.183.10;r2=on;lr=on;ftag=156009dabfd12b0]
    Record-Route: [sip:172.29.183.7;lr=on;ftag=156009dabfd12b0]
    Contact: [sip:06509796299@172.29.183.102:5062]
    To: [sip:018903642200@p1.voip.inode.at]
    From: [sip:06509796299@p9.voip.inode.at];tag=156009dabfd12b0
    Call-ID: 2f8f77406c739806aecd0cfa6b2bb08c@p9.voip.inode.at
    CSeq: 1468900846 INVITE
    Session-Expires: 600
    Supported: timer, replaces
    User-Agent: Patton SN2400 MxSF v3.2.8.45 00a0ba00ac60 R3.21 2007-09-14_RFE10808 H323 SIP
    P-Preferred-Identity: [sip:06509796299@172.29.183.102]
    Content-Length: 0

    Did I fill in the fields wrong?

    Thanks,
    Ernst
     
  4. Powermage

    Powermage New Member

    Joined:
    Mar 19, 2008
    Messages:
    103
    Likes Received:
    0
    If u use an * as the DID and select the voip provider, what do you get then?
     
  5. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    Where would I use the * ?

    Could you show me how it should look like?
     
  6. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    I have tried it in the following way

    DID Settings

    Name 510
    DID/DDI number/mask *510*
    Override incoming Caller ID with DID name checked

    VOIP Provider: Inode

    Connect to Extension: 510

    Still the same problem


    11:29:23.609 evt::CheckIfAuthIsRequired::not_handled [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:018903642510@172.29.183.103:5060;rinstance=8f12b17e4b3db109 SIP/2.0
    Via: SIP/2.0/UDP 212.41.253.181;branch=z9hG4bKfb58.2ec0d162.0
    Via: SIP/2.0/UDP 172.29.183.15;rport=5060;branch=z9hG4bKfb58.28ff9ab2.0
    Via: SIP/2.0/UDP 172.29.183.103:5062;branch=z9hG4bK7bb16401b
    Max-Forwards: 69
    Record-Route: [sip:212.41.253.181;r2=on;lr=on;ftag=40f06e1165d00fc]
    Record-Route: [sip:172.29.183.10;r2=on;lr=on;ftag=40f06e1165d00fc]
    Record-Route: [sip:172.29.183.15;lr=on;ftag=40f06e1165d00fc]
    Contact: [sip:0676840374203@172.29.183.103:5062]
    To: [sip:018903642510@p1.voip.inode.at]
    From: [sip:0676840374203@p9.voip.inode.at];tag=40f06e1165d00fc
    Call-ID: a899bb498b0b700fea31f87e976e762c@p9.voip.inode.at
    CSeq: 1716034216 INVITE
    Session-Expires: 600
    Supported: timer, replaces
    User-Agent: Patton SN2400 MxSF v3.2.8.45 00A0BA020B1D R3.21 2007-09-14_RFE10808 H323 SIP
    P-Preferred-Identity: [sip:0676840374203@172.29.183.103]
    Content-Length: 0

    11:29:23.609 evt::CheckIfAuthIsRequired::not_handled [CM302001]: Authorization system can not identify source of: SipReq: INVITE 018903642510@172.29.183.103:5060 tid=fb58.2ec0d162.0 cseq=INVITE contact=0676840374203@172.29.183.103:5062 / 1716034216 from(wire)
     
  7. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Open Source identification section for Patton gateway and set following:
    SIP Field | Value | Custom Value
    Request Line URI : Host part | Custom Field | 172.29.183.103:5060
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    Hi,

    I have asked the provider to do so - but they did tell me they can´t because all of their customers are on the same patton box and so it could be a problem for the others.

    Any other Idea - I would like to stick with 3cx and not go back to asterisk - because I like the way the system looks like

    But I need to make it working

    best regards,
    Ernst
     
  9. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Sorry, do you have administrator's rights for you 3CX PBX box or not? I was speaking about settings of 3CX box. That Patton is not in your posession? Is it on some VoIP provider's site?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    Hi,

    our configurations is as follow

    we have a telecom provider named Inode and we have there the Telenode TITAN Package which works with SIP Protokol.

    On our Side we have a PC with the 3CX Software which we did configure using the base settings for the Generic VOIP Provider.

    The provider sends us the calls directly over VOIP with the SIP Protokol to our 3CX Telefon system.

    We do not have any Patton Box inbetween.

    And the connections works because we can call out.

    But unfortunatly not in!

    Thanks,
    Ernst
     
  11. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Than open "Edit VOIP Provider" page for your provider in 3CX Management console and in section Source identification apply the changes I've mentioned above
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    Thanks - it works!!!

    The only question now still is how can I adress the extensions.
    Every call which comes in goes to the routed inbound extension.

    Chears,
    Ernst
     
  13. h2009

    h2009 Member

    Joined:
    Mar 15, 2008
    Messages:
    447
    Likes Received:
    0
    Sorry can you clarify what you want the incoming call to do please. Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. macher

    Joined:
    Mar 31, 2008
    Messages:
    8
    Likes Received:
    0
    Good morning!

    Yes of course.

    We have 7 extensions for our phones and one fax line.

    This extension are Numbered from 200 to 206.
    We would like that our customers can directly call trough to the needed person.
    And if someone calls the headnumber it should ring at just one extension.

    i.e. if someone calls 01 890 4236 or 01 890 4236 he should come to extension 200

    or if someone calls 01 890 4236 205 or 01 890 4236 203 he should come to the called person.
    or if he calls 01 890 4236 150 he should be connected to the telefax machine.

    So people should be able to call trough.
    The SIP line incorporates the requested extension

    like
    INVITE sip:018903642200@172.29.183.103:5060;rinstance=035e9f46a90a9e71 SIP/2.0
    or
    INVITE sip:018903642510@172.29.183.103:5060;rinstance=8f12b17e4b3db109 SIP/2.0

    Thanks,
    Ernst
     
  15. FITEC

    Joined:
    Sep 15, 2008
    Messages:
    19
    Likes Received:
    0
    noticed that 0 is usually appended when someone calls the headnumber (without extension) - try to set SIP-ID 0 at the receptionist's extension

    check if the SIP-ID at the extension is set to 205, 203 or 150
     
  16. mickp

    Joined:
    Jun 9, 2008
    Messages:
    72
    Likes Received:
    0
    Um. I don't think sip id is what you want to be looking at. Sip id is for internet calls with user@your.domain.name style calls afaik.

    Mick.
     
  17. mickp

    Joined:
    Jun 9, 2008
    Messages:
    72
    Likes Received:
    0
    If I understand your request correctly, you have a working sip trunk and just need to configure some did (direct in-dial) numbers. My appologies if I'm missing the point and there's some other issue. Review the instructions http://www.3cx.com/manual/3CXPhoneSystemManual6/phone-system47.html and see how you go.

    Mick.
     
  18. FITEC

    Joined:
    Sep 15, 2008
    Messages:
    19
    Likes Received:
    0
    you're absolutely right, Mick, The SIP-ID is used for internet calls but in this scenario it seems that the sip-provider uses a different field for the DIDs. will check if it's related to Source identification section (http://www.3cx.com/forums/source-id-problem-which-could-not-be-solved-4819.html#p38255) and let you know.

    DID does not work in this scenario - but in any case it's related to the SIP-provider because it works with a different one :x
     
Thread Status:
Not open for further replies.