SPA-3102 and 3cx : Can't see Caller-ID

Discussion in '3CX Phone System - General' started by stamos, Jul 24, 2007.

  1. stamos

    Joined:
    Jul 24, 2007
    Messages:
    5
    Likes Received:
    0
    Hello,
    I can't see the Caller-ID on the logs of 3cx and also on the phone screens.
    I am using Linksys SPA-3102 for attaching the PSTN Line.I can see the caller-id on the Linksys-SPA-3102 .
    Does anybody had the same problem with me and solved it ?

    Thank you
    Stamos
     
  2. jits04

    Joined:
    May 2, 2007
    Messages:
    76
    Likes Received:
    0
    Hi,

    set PSTN Answer Delay to: 3 (or 4)

    Bye

    William
     
  3. Anonymous

    Anonymous Guest

    William, that is just slack LOL.

    It is a bit more involved than that.

    In 3CX you have to configure:

    Edit VoIP Gateway
    Gateway capabilities: Supports re-Invite tick this

    Location of destination number:
     
  4. stamos

    Joined:
    Jul 24, 2007
    Messages:
    5
    Likes Received:
    0
    Thank you ,
    I have done all these , but I had also to do the following on the Sipura-3102:
    PSTN Line
    PSTN CID For VoIP CID:Yes

    Now it works.

    Thank you
     
  5. Fallout

    Joined:
    Oct 10, 2006
    Messages:
    12
    Likes Received:
    0

    Everyone misses this...It is the most important part....
     
  6. Anonymous

    Anonymous Guest

    I guess it is so obvious that it is not mentioned.

    But good point, Ill make sure i add it to the doco.
     
  7. onekit

    Joined:
    Aug 3, 2007
    Messages:
    27
    Likes Received:
    0
    With such setting my phone (which connected to SPA port "Phone") ring for this time and then redirect to 3CX.

    It seems like I hear the ring on the phone which I don't want ring.
    My 3cx phone system redirect calls to another sip phone, not connected to SPA.

    I know this issue is not associated with 3cx, it's trouble of SPA-3102, but may be you know solution how to keep phone in silence.

    Added:
    If I set PSTN Answer Delay: 1.5 - then connected phone silent.

    And one question: May be I need additional phone with ability Caller ID detection? Or my SPA-3102 must detect caller ID self?
     
  8. onekit

    Joined:
    Aug 3, 2007
    Messages:
    27
    Likes Received:
    0
    What about settings in "Voice -> Regional" tab?
    Exactly fields "Caller ID Method" and "Caller ID FSK Standard". Is it important? I think it so.
     
  9. Cjay

    Cjay New Member

    Joined:
    Feb 24, 2007
    Messages:
    187
    Likes Received:
    0
    This depends on your caller ID system. For example in the UK the CID data is sent as FSK before the first ring, so you can set the answer delay to 0. This makes my VoIP phones ring at almost the same time as the conventional analogue phones. Other CID standards send the CID data burst between the first & second ring - in which case you do need the answer delay.

    You must set your Caller ID method to the correct standard, so the regional setting is important!

    Cjay
     
  10. Anonymous

    Anonymous Guest

    Correct Cjay,

    appart from that it only works with the BellCore standard (again one of those undocumented gotchas).
     
  11. onekit

    Joined:
    Aug 3, 2007
    Messages:
    27
    Likes Received:
    0
    My problem was in PBX.
    And works good with such settings:

    PSTN Answer Delay: 2
    PSTN Ring Thru Delay: 1

    But now I need to convert caller id number to international format. ;) But it's offtopic already.
     

Share This Page