SPA-3102 problems...

Discussion in '3CX Phone System - General' started by subh, Dec 14, 2007.

  1. subh

    Joined:
    Dec 4, 2007
    Messages:
    28
    Likes Received:
    0
    Hi...

    Bought SPA-3102 yesterday, but having following problems:

    1. After getting connected to Digital Receptionist, after a few secs, it gets disconnected. Log as below:

    ------------------
    06:46:51.765
    StratInOut::eek:nHangUp
    [CM104007] Call(8): Call from Ln:10000@SPA-3102 to 100 has been terminated by Ln:10000@SPA-3102; cause: unknown

    06:46:21.515
    CallLegImpl::eek:nConnected
    [CM103001] Call(8): Created audio channel for Ln:10000@SPA-3102 (192.168.1.2:16406) with Media Server (192.168.2.2:7014)

    06:46:18.500
    CallConf::eek:nIncoming
    [CM103002] Call(8): Incoming call from 10000 (Ln:10000@SPA-3102) to sip:10000@192.168.2.2

    --------------
    06:20:53.765
    StratInOut::eek:nHangUp
    [CM104007] Call(7): Call from Ln:10000@SPA-3102 to 100 has been terminated by Ln:10000@SPA-3102; cause: unknown

    06:20:21.703
    CallLegImpl::eek:nConnected
    [CM103001] Call(7): Created audio channel for Ln:10000@SPA-3102 (192.168.1.2:16400) with Media Server (192.168.2.2:7012)

    06:20:21.656
    CallConf::eek:nIncoming
    [CM103002] Call(7): Incoming call from 10000 (Ln:10000@SPA-3102) to sip:10000@192.168.2.2
    --------------

    Digital Receptionist call flow:

    DR 100 --> Play Msg, wait for 2 secs, forward to DR 101.
    DR 101 --> Play Msg, wait for 1 sec, forward to extn 102.
    Ex 102 --> Forward to Voice Mail

    I have tested this with X-Lite and 3cx Phone, and it's working fine.

    At SPA-3102 Info Page, it shows :
    Last PSTN Disconnect Reason: VoIP Gateway Call Timeout



    2. After disconnecting the call, 3102 does not hang up the line. It releases the line after say 5 mins or so.

    SPA setting:

    PSTN Disconnect Detection

    Detect CPC: Yes
    Detect PSTN Long Silence: No
    PSTN Long Silence Duration: 30
    PSTN Silence Threshold: medium
    Detect Disconnect Tone: Yes
    Disconnect Tone: 400@-30,100@-30;10(.8/.8/1+2)
    Detect Polarity Reversal: Yes
    Detect VoIP Long Silence: No
    VoIP Long Silence Duration: 30
    Min CPC Duration: 0.2


    Any help would be highly appreciated.

    BTW, I'm from India and use MTNL line.

    TIN
     
  2. jantoney

    Joined:
    Nov 20, 2007
    Messages:
    60
    Likes Received:
    0
    Disconect tone

    hey try change the disconnect tone to

    400@-30,400@-30;10(.8/.8/1+2)

    this is something i found on the net for india!
    i had similar issues in australia where mine wasn't releasing the call.
    i found the correct tone for australia and it worked fine after that.
     
  3. subh

    Joined:
    Dec 4, 2007
    Messages:
    28
    Likes Received:
    0
    Thanks, Jay.

    I have found the correct disconnect tone for India (MTNL) :

    400@-10,400@-10;10(.75/.75/1+2)

    There are few other settings that I found which are working for MTNL, India for SPA-3102. In Regional Tab:

    Dial tone : 400@-10,375@-10;10(*/0/1+2)

    Busy tone : 400@-19,400@-10;10(.75/.75/1+2)

    Reorder Tone : 400@-10,400@-10;10(.75/.75/1+2)

    Ringback tone : 400@-10,375@-10;*(.5/.25/1+2,0/2/0,.5/.25/1+2)


    So, phone is getting released after the other side phone is disconnected.

    However, still the connection gets lost in between just around 32 seconds every time.

    Any solution would be highly appreciated.

    TIN
     
  4. jantoney

    Joined:
    Nov 20, 2007
    Messages:
    60
    Likes Received:
    0
    logs

    Hey glad thats working now!

    Can you please post the logs for a call now thoes other settings have changed..
     
  5. subh

    Joined:
    Dec 4, 2007
    Messages:
    28
    Likes Received:
    0
    Hello Jay,

    It's the same as before...


    -----------
    3:12:27.984
    StratInOut::eek:nHangUp
    [CM104007] Call(20): Call from Ln:10000@SPA-3102 to 100 has been terminated by Ln:10000@SPA-3102; cause: unknown

    13:12:22.218
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:21.624
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:21.171
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:20.656
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:16.671
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:16.046
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:14.484
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:10.765
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:09.781
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:12:08.796
    MediaServerReporting::DTMFhandler
    [MS211000] Call(20) Ln:10000@SPA-3102: DTMF (in-band) from 192.168.1.2:16388 detected.

    13:11:55.874
    CallLegImpl::eek:nConnected
    [CM103001] Call(20): Created audio channel for Ln:10000@SPA-3102 (192.168.1.2:16388) with Media Server (192.168.2.2:7038)

    13:11:55.827
    CallConf::eek:nIncoming
    [CM103002] Call(20): Incoming call from 10000 (Ln:10000@SPA-3102) to sip:10000@192.168.2.2

    -------

    See that it's exactly 32 seconds (excluding decimals). But this time, SPA Info shows that :

    Last PSTN Disconnect Reason: PSTN Disconnect Tone

    Hope this helps....
     
  6. subh

    Joined:
    Dec 4, 2007
    Messages:
    28
    Likes Received:
    0
    SPA-3102 Experts!

    Hi...

    The problem still exists, disconnecting with "unknown" cause after 32 secs.

    Also, I'm not able to get caller id. I'm from India.

    Any help would be highly appreciated.

    TIN
     
  7. subh

    Joined:
    Dec 4, 2007
    Messages:
    28
    Likes Received:
    0
    Well...

    I read similar problem somewhere in this forum and just followed it. It was simple.

    Backup data --> Uninstall --> Reinstall --> Restore Data.

    And the calls are now ON for minutes after minutes. ;)

    Hope this helps...
     

Share This Page