Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

spa 504g and V15 provisioning

Discussion in '3CX Phone System - General' started by choksw, Oct 24, 2016.

Thread Status:
Not open for further replies.
  1. choksw

    Joined:
    Oct 24, 2016
    Messages:
    6
    Likes Received:
    1
    Hi All,

    My 3CX is hosted on a VPS online, and I am having problems provisioning my SPA504g phones.

    Previously, I have tried to provision spa504g with a locally installed 3CX v15 and the provision was without a hitch. However, after moving my 3cx installation to a VPS online, I am unable to provision the SPA504g phones, even with a site to site vpn.

    These are the scenarios I tried and the responses:

    Scenario 1 : Manual provision of SPA504g using web panel.
    1. Tried provisioning using http://192.168.1.155/admin/resync?http: ... XX/$MA.xml but the SPA504g did not resync and restart.
    2. So I tried to hit http://mydomain:5000/provisioning/XXX/$MA.xml in the web browser but browser returns SSL protocol error code. Apparently, it keeps redirecting to https:// but at port 5000.
    3. So I tried https://mydomain:5001/provisioning/XXX/$MA.xml but there was no response

    Scenario 2: Using site to site VPN
    1. using the same manual provision method, I replaced the provisioning URL to http://mydomain:5000/provisioning/XXX/$MA.xml go http://192.168.1.11:5000/provisioning/XXX/$MA.xml and http://192.168.1.11/provisioning/XXX/$MA.xml but it did not work.

    At all instances, after punching in the manual provision address I was able to redirect to the SPA504g "SPA will resync the profile when it is not in use and reboot." page, but the phone just doesnt reboot.

    My instinct tells me that the manual provisioning url http://mydomain:5000/provisioning/XXX/$MA.xml could not be reached. It also keeps redirecting to https.

    Anybody care to help please? Thank You.
     
  2. Anonymous

    Anonymous Guest

    We had SPA504g with 12.5 connected remotely. It mostly worked. As you know 3CX doesn't support the SPA504g at remote locations.

    If you're concerned that the phones don't reach 3cx for provisioning, what you could do is connect a laptop and put the provisioning url in the address bar. Just make sure you put the MAC of the spa504g in the provisioning string as the variable will not work. ie

    http://mydomain:5000/provisioning/XXX/$MA.xml

    becomes
    http://mydomain:5000/provisioning/XXX/<11aa22cc33dd>.xml where <11aa22cc33dd> is the cisco504g mac

    You should be able to download the provisioning file in your browser.
     
  3. choksw

    Joined:
    Oct 24, 2016
    Messages:
    6
    Likes Received:
    1
    Re: spa 504g and V15 provisioning [SOLVED]

    == SOLVED ==

    Dear All,

    I have managed to solve the above issue. Just to reiterate, this is for 3CX hosted in the cloud, or Windows VPS and hopefully it helps anyone who may want to auto-provision end of life phones like the SPA504g and Yealink T21P.

    To provision end of life phones behind the SBC, or without SBC, pure remote phones, we need to first edit the nginx.conf configuration text file to allow your office location (a remote location).

    Go to: "C:\Program Files\3CX Phone System\Bin\nginx\conf\nginx.conf" and open it with "Notepad" or any text editing app.
    Look for the following block:

    You may add your remote location IP address here. Remember to put a semicolon at the end of the line. If your remote location has a dynamic IP address, you may remove the whole block above and enter "allow all;" with the semi colon. Remember this is for provision only. After provisioning, you may change the config back to original for stronger firewall.

    After you have changed the necessary and saved the configuration file, open services.msc by pressing windows+R, restart the "3CX Nginx" service to reload the config files.

    After which, you may be able to provision your phones.

    Some of you have asked what about site to site VPN? I have tried site to site vpn but I am unable to get the 3CX server to join the multicast group and I suspect that's the reason why the remote phones cannot be provisioned.

    Good luck!
     
    Telcreek likes this.
  4. ZenMasta

    ZenMasta New Member

    Joined:
    Mar 10, 2010
    Messages:
    174
    Likes Received:
    0
    Anyone figure this out on linux?
    I don't see any block similar to what your describing. I checked
    /etc/nginx/nginx.conf
    /etc/nginx/sites-available/default
    /etc/nginx/sites-enabled/default
     
  5. hwcltjn

    Joined:
    Aug 16, 2017
    Messages:
    26
    Likes Received:
    1
    There should be a symlink in sites-enabled on Debian - if not the NGINX configuration is located at:
    /var/lib/3cxpbx/Bin/nginx/conf/nginx.conf
     
Thread Status:
Not open for further replies.