Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

SPA508G Registration Question

Discussion in '3CX Phone System - General' started by casualmikey, Aug 26, 2010.

Thread Status:
Not open for further replies.
  1. casualmikey

    Joined:
    Jul 24, 2010
    Messages:
    21
    Likes Received:
    0
    Hi all,

    I just received some new SPA508G phones (firmware 7.4.3a) and I followed the instructions about how to provision those phones (wihout option 66). I followed all instructions on setting up extensions and phone profile rule but it did not work. I checked the phone server logs and the phone was not even attempting registration.

    After quite a bit of troubleshooting, I figured out how to get it to work. On the phone (ext 1 tab), I had to set the proxy field to point to the server with port 5060. I also had to manually set the user id, auth id, and password in order for the phone to register.

    I'm wondering why provisioning didn't take care of all of this setup for me. Supposedly all I had to do was set the profile rule to point to the management site and the phone would do the rest.

    I'm running windows web server 2008 r2 and using IIS 6.1

    Thanks in advance for your advice and help.

    Mike
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    Your correct it should have do it all for you.

    1. What version of 3cx are you using.
    2. What is the firmware version of the phone.
    3. Did you ever upgrade your pbx from another? (7-8,8-9) etc.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. casualmikey

    Joined:
    Jul 24, 2010
    Messages:
    21
    Likes Received:
    0
    Hi,

    Phone firmware is now 7.4.6, the latest as of today. I'm using version 9 build as of a few days back. This is a new installation with IIS 6. I also noticed this similar behavior on the SPA501 on version 8 (different machine) sometime back but never brought the issue forward.

    I tried to the force sync by using the url below but it just tells me that phone will resync when it is not in use or when it reboots. Nothing happens other than even after restarting phone.

    http://PhoneIP/admin/resync?http://ServerIP/management/provisioning/$MA.xml
     
  4. casualmikey

    Joined:
    Jul 24, 2010
    Messages:
    21
    Likes Received:
    0
    I also just tried to link to the xml configuration file for the phone in the browser but it came up with a blank page. Not a 404 page not found, just a blank page.

    http://ServerIP/management/provisioning/0002TDFE4013.xml

    Should I be able to view the config file for the phone directly through the browser?
     
  5. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    Yes you should, it seem that somewhere along the lines your files have blanked out, I recommend you run a backup, and resinstall the PBX, that should replace your old files with new ones and solve this issue for you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. casualmikey

    Joined:
    Jul 24, 2010
    Messages:
    21
    Likes Received:
    0
    What's interesting is when I navigate to the xml configuration files using windows explorer for those MAC id's I setup, they were full configurations. They were not blanked out. I thought it might be a permission issue so I allowed ALL permissions to those folder through IIS (for testing of course). But no luck.

    I tried reinstalling 3cx several times as well. It works when I use Abyss web server. There's something with IIS config that is either intercepting the *.xml http request and not allowing it to be sent back. I looked at filter request to specifically allow .xml request but that also didn't work. I'd really like to use IIS as the admin is extensive and very easy to install certs, etc. I'm not at all familiar with Abyss or its scalability and stability.
     
Thread Status:
Not open for further replies.