SPA941 As External Extension

Discussion in '3CX Phone System - General' started by digitalrampage, Aug 24, 2007.

  1. digitalrampage

    Joined:
    Aug 24, 2007
    Messages:
    4
    Likes Received:
    0
    :?: So I have set up external extensions and connect from home to my office using x-lite software and the 3cx STUN server, but I can not get my SPA-941 phone to connect.

    The extension i'm trying to connect to can be used perfectly from X-lite outside my office network, but the SPA-941 can not even register.. I think it has to do with STUN/NAT settings etc.

    Not being a networking geek I can't figure it out and its driving me nuts.

    Can anyone offer advice?

    Thanks

    P.S I do have the extension set up to BIND and its marked as an external extension.
     
  2. RobLloyd

    RobLloyd Member

    Joined:
    Oct 13, 2006
    Messages:
    488
    Likes Received:
    0
    Are you using a static IP to register your 941? I believe you also need NAT keepalive turned on. These are phone settings you need to configure in the web interface of the 941.
     
  3. digitalrampage

    Joined:
    Aug 24, 2007
    Messages:
    4
    Likes Received:
    0
    the phone is sitting behind a router on dhcp with an adress of 192.168.2.2.

    There is quite a few nat supprt parameters

    as in...
    NAT Support Parameters
    Handle VIA received: Handle VIA rport:
    Insert VIA received: Insert VIA rport:
    Substitute VIA Addr: Send Resp To Src Port:
    STUN Enable: STUN Test Enable:
    STUN Server: EXT IP:
    EXT RTP Port Min: NAT Keep Alive Intvl:

    currently everything but the stun server enable is off and the stun is set to stun.3cx.com


    I Should also mention, I have had to set my router to route port 5600 to port 5060 as the billion will not allow traffic on 5060 due to the built in VOIP ports. So 5600 traffic goes to 5060 internally. I thought this may be an issue but x-lite does care.. it works using my fqdn:5600
     

Share This Page