Specific Office Hours - not working

Discussion in '3CX Phone System - General' started by Peter Richardson, Nov 15, 2017.

Thread Status:
Not open for further replies.
  1. Peter Richardson

    Peter Richardson New Member

    Joined:
    Apr 6, 2017
    Messages:
    219
    Likes Received:
    9
    Hi all,

    If I have "Set Specific Office Hours For This Trunk" for 8am - 5pm, then how would a call get through last night at 8:57pm?

    Screenshot 2017-11-15 11.20.22.png

    Screenshot 2017-11-15 11.21.47.png
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    Hello @Peter Richardson

    Do you have additional trunks on the PBX ? Direct SIP call on the extension? Is extension 107 set as the operator of the PBX?
     
  3. Peter Richardson

    Peter Richardson New Member

    Joined:
    Apr 6, 2017
    Messages:
    219
    Likes Received:
    9
    Thanks @YiannisH_3CX

    Yes I have 4 trunks.

    No we don't have anyone that uses direct SIP calls.

    I have just searched in "Parameters" and found that 107 is indeed the operator extension.

    1) Is this the normal place to change the operator extension
    2) What is the purpose of the operator role as opposed to a normal extension?
    3) Why doesn't 3CX obey the specific trunk hours, ring groups, etc and route them correctly instead of sometimes sending it to the operator? IE: if it's outside business hours, it should just go to voicemail, as configured.
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    Operator extension can be set through Settings / PBX.
    The reason i asked if extension 107 is the operator extension is because there is an option in the Voicemail menu where you can press * to contact the operator extension. So if i had to guess about what happened i would guess that the call was forwarded to voicemail as specified and the caller press * which forwarded the call to the operator extension.
     
  5. Peter Richardson

    Peter Richardson New Member

    Joined:
    Apr 6, 2017
    Messages:
    219
    Likes Received:
    9
    Thanks @YiannisH_3CX

    You're probably right about that. How can I disable this feature? There's no option to disable the operator extension, or to just deliver the call to voicemail of an extension. I don't want the operator extension and I don't want people to be able to break through the iron curtain of Specific Office Hours.
     
  6. panda

    Joined:
    Feb 16, 2016
    Messages:
    16
    Likes Received:
    0
    What timezone is your os set to? I made the same mistake for my servers.
     
  7. Peter Richardson

    Peter Richardson New Member

    Joined:
    Apr 6, 2017
    Messages:
    219
    Likes Received:
    9
    Thanks @panda I just checked that and I'm on the right time zone. Good thought though.

    I just noticed another office hours setting in the section settings -> timezone -> Configure Office Hours. What reason could there be for a second set of office hours?
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    The operator extension cannot be disabled, you can however either change the prompt so that users do not get this prompt or create a dummy operator extension that forwards the call to an IVR with a message and End Call after 1 second. This way no phones will be ringing after hours.

    The second row of office hours is for Break times. You can set Break times so that you extensions are auto set to Away during this time
     
  9. Peter Richardson

    Peter Richardson New Member

    Joined:
    Apr 6, 2017
    Messages:
    219
    Likes Received:
    9
    Thanks @YiannisH_3CX

    That makes sense!

    But with the second set of office hours, what I meant was that it is possible to set the office hours in:

    settings -> timezone -> Configure Office Hours
    and
    sip trunks -> (trunk) -> Set up Specific Office Hours for this trunk

    this seems like the same setting twice. I couldn't think of a reason why it would be repeated, can you?
     
  10. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,367
    Likes Received:
    83
    Whether you set the operator extension to follow Global of Specific Office Hours, in your case I guess it should have the same result, just make sure that the Forwarding Rules are set up for the Operator Extension to accordingly so that you get the behavior you want, like "End Call" if I understand correctly.
     
  11. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    The office hours under Settings / Timezone are the global office hours. What you set there affects the whole system unless specific office hours are set.
    The office hours under a sip trunk are specific office hours, and affect only the trunk the office hours are set under. When set the trunk will follow it's own office hours ignoring the systems office hours.
    So you can have a trunk or an extension follow different office hours that the rest of the system. This provides better flexibility in your configuration.
     
Thread Status:
Not open for further replies.