Solved SSL Certificate on Cloud Install

Discussion in '3CX Phone System - General' started by Darren Birnie, Apr 3, 2018.

  1. Darren Birnie

    Joined:
    Apr 3, 2018
    Messages:
    3
    Likes Received:
    0
    Hello,

    I have 3CX hosted on Google's cloud platform. Everything was working then i tried to login to the 3cx console and got the error below. I assume this is a certificate problem, but unsure how i resolve the issue. Any help would be appreciated.

    *******.3cx.us normally uses encryption to protect your information. When Google Chrome tried to connect to ********.3cx.us this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be ******.3cx.us, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

    You cannot visit ********.3cx.us right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.
     
  2. Saqqara

    Saqqara Active Member

    Joined:
    Mar 12, 2014
    Messages:
    697
    Likes Received:
    99
    What happens if you try connecting using another browser.
     
  3. Darren Birnie

    Joined:
    Apr 3, 2018
    Messages:
    3
    Likes Received:
    0
    This is what i get on Edge:

    The website’s security certificate is not yet valid or has expired.
    Error Code: DLG_FLAGS_SEC_CERT_DATE_INVALID
     
  4. Saqqara

    Saqqara Active Member

    Joined:
    Mar 12, 2014
    Messages:
    697
    Likes Received:
    99
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    3,496
    Likes Received:
    239
    Hello @Darren Birnie

    If you haven't sorted out your issue yet please send me a p.m. so we can look into it for you.
     
  6. Darren Birnie

    Joined:
    Apr 3, 2018
    Messages:
    3
    Likes Received:
    0
    Anyone who finds this post, my version on 3CX was outdated. This was a result of the repo being moved for the pbx express install. https://www.3cx.com/blog/docs/pbx-express-repo-change/

    Get root (sudo -s google cloud)

    1. Follow post to update repo
    2. apt-get update
    3. apt-get upgrade
    4. apt-get upgrade 3cxpbx
    5. Login and update all 3cx (I had to use edge to get past ssl error)
    6. Wait 24hrs cert will fix itself.

    Darren
     
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    3,496
    Likes Received:
    239
    Glad to see the issue has been resolved and thank you for sharing your solution.