STATIC NAT, only problem to mobile numbers

Discussion in '3CX Phone System - General' started by pc17, Oct 12, 2009.

Thread Status:
Not open for further replies.
  1. pc17

    Joined:
    Jul 31, 2009
    Messages:
    5
    Likes Received:
    0
    Hello,

    I've a strange problem, everything is working, however, when I connect with siptraffic (which we use for mobile numbers), in about 50% we have a working connection.
    45% we only have one way audio (audio in is OK, but the people can't hear us).
    5% of the time, we get an error from the server (number is not registered... while it is)

    SETTING AND INFO REGARDING SERVER

    Running v8 rtm.
    STUN disabled.
    Server with 2 NICs (192.168.0.1 (network) and 192.168.254.3 (to vdsl modem).
    Modem LAN is 192.168.254.1 (all ports forwarded to 192.168.254.3)
    Modem WAN is 91.x.x.x (directly to internet)

    Public IP to specify in Contact and SDP 91x.x.x.x
    Select network interface: 192.168.254.3

    SIPTRAFFIC:
    SIP: sip.siptraffic.com port 5060
    OUTBOUND PROXY: sip.siptraffic.com port 5060
    CLID is set: (outbound parameters, From: user part, custom field)

    PHONES:
    Siemens C470IP

    All servers are putted in (192.168.0.1).
    STUN DISABLED
    Outbound proxy 192.168.0.1 (always)

    HOWEVER, here it is, if I configure the phones to connect with outbound proxy sip.siptraffic.com immediately, everything works like a charm, except internal calls.
    This is because it excludes the server obviously.

    Can you guys figure this out?
    I've also tried with stun (stun.siptraffic.com or stun.justvoip.com).

    Thx in advance!
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,567
    Likes Received:
    246
    More often than not, one way audio (and other) problems are a result of blocked ports. Have you run the firewall checker within 3CX? Has the problem always been there or did it begin after some sort of a change on your network/system?
     
Thread Status:
Not open for further replies.