System Database Server Error

Discussion in '3CX Phone System - General' started by agnetman, Oct 2, 2007.

  1. agnetman

    Joined:
    Oct 2, 2007
    Messages:
    24
    Likes Received:
    0
    After downloading today and installing the free edition on a Windows 2003 Standard Edition SP2 server in a workgroup, I get this message when I try and open the management console.

    "Can't connect to the database server - server unreachable".

    I can see using TCPView that the server is not listening on port 5480.

    Checking the services mmc shows that the 3CX database server service has not started.

    The service cannot be started even when logged in and using the administrator's credentials. When trying to start the service manually I get an error 5 access denied message.

    I have tried uninstalling, deleting all files, restarting and reinstalling several times, but still the same sitaution.

    How is this service started?

    Here's the detailed error output.

    "SQLSTATE[08006] [7] could not connect to server: Connection refused (0x0000274D/10061)
    Is the server running on host "???" and accepting
    TCP/IP connections on port 5480?
    #0 C:\Program Files\3CX PhoneSystem\Data\Http\functions\CallContext.php(37): PDO->__construct('pgsql:dbname=ph...', 'administrator', '*******')
    #1 C:\Program Files\3CX PhoneSystem\Data\Http\functions\CallContext.php(86): CallContext->getConnection()
    #2 C:\Program Files\3CX PhoneSystem\Data\Http\functions\fExtension.php(66): CallContext->safeExec('select DN.IDDN ...', Array, 'Cannot get Exte...')
    #3 C:\Program Files\3CX PhoneSystem\Data\Http\functions\fObject.php(90): fExtension->getData()
    #4 C:\Program Files\3CX PhoneSystem\Data\Http\index.php(7): fObject->getManager()
    #5 {main}
     
  2. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    Add the same problem myself here, try to give permission to the 3CXPhonesystem to the drive where your have 3CX installed. you can also try to give access only to 3cx folder but i dont know if it will work. When i say give acess i mean, administrator access to 3cxphonesystem user to that drive or folder... Worked here..

    Cheers
     

Share This Page