Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved System Extensions Unregistered, IVR Service Will Not Start

Discussion in '3CX Phone System - General' started by Marari, Feb 22, 2018.

Thread Status:
Not open for further replies.
  1. Marari

    Marari New Member

    Joined:
    Sep 16, 2007
    Messages:
    207
    Likes Received:
    47
    Ver: 15.5.8801.3 PRO
    Platform: Google Cloud Hosted
    Machine Type: g1-small (1 vCPU, 1.7 GB memory) (I know it's overkill but more is better)

    Issue:
    IVR service does not start. Will not start. Can not start.
    ALL system extensions show as unregistered (including IVR, which is probably why it won't start...)

    Action taken so far:
    Stop the VM via graceful shutdown, restart. Same issue.
    Restore from last (good) backup. Restart. Same issue.
    Restore from initial (good) backup). Restart. Same issue.
    Delete VM. Recreate VM using pbxexpress.3cx.com. Restore last (good) backup. Same issue.
    Move instance. Create new VM. Manually install 3cxpbx via CLI. Restore last (good) backup. Same issue.
    Curse and swear. Same issue, but I feel marginally better.

    Any help is appreciated. Logs are not showing WHY the system extensions are coming up unregistered.

    Images as follows:

    [​IMG]

    [​IMG]

    [​IMG]
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,353
    Likes Received:
    535
    Hello @Marari

    Is the service down before you restore the backup or does it not start after the backup is restored? Also from what version is the backup taken from? Do you have any custom prompts? If so remove them and try to start the service again.
     
  3. Marari

    Marari New Member

    Joined:
    Sep 16, 2007
    Messages:
    207
    Likes Received:
    47
    Helo @YiannisH_3CX

    I hadn't checked to see, actually. It looks as though the Google Cloud platform changed the external IP address (it was dynamic) and that's when the trouble all started. However, even after doing a complete fresh install and a restore, the issue is still present.

    I've removed the custom IVR prompt (which was recorded as per the spec using audacity) and the music on hold playlist (which was also in spec using audacity), and now the services are back up, as is the IVR.

    **edit** the IVR and System Services are down after a refresh of the dashboard.

    Deleting the custom prompts did not fix the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,353
    Likes Received:
    535
    Please check your inbox as i have sent you a p.m. with what we will need to further troubleshoot your issue.
     
  5. Marari

    Marari New Member

    Joined:
    Sep 16, 2007
    Messages:
    207
    Likes Received:
    47
    Thanks for the AWESOME help @YiannisH_3CX

    We were able to narrow down the issue to a segmentation fault in the libssl module. The fault was actually not related to 3CX but rather to the google cloud console and their instructions on enabling 3rd party remote SSH access to the VM.

    Consider this one solved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,353
    Likes Received:
    535
    Glad the issue has been resolved and thank you for updating the post with your solution :)
     
Thread Status:
Not open for further replies.