T42g CTI Not Functioning Properly

Discussion in '3CX Phone System - General' started by JDoerflinger@ercopco.com, Jun 26, 2017.

Thread Status:
Not open for further replies.
  1. JDoerflinger@ercopco.com

    Joined:
    Nov 6, 2014
    Messages:
    1
    Likes Received:
    0
    Not sure what I am missing here, I thought CTI was pretty straightforward and automatic on Yealink phones.

    3CX 14
    Windows 3CX Phone (Set to CTI and shows phone connected)
    Yealink T42g (29.81.0.110)
    Windows desktop connected to network via the PC port on phone

    3CX phone has no control over the desk phone. If I answer the softphone, the user doesnt get answered, and the deskphone keeps ringing. Call starts once deskphone is answered. Further, hanging up on the softphone does nothing.

    Is this right?

    Thanks!
    -Jim
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Hello @JDoerflinger@ercopco.com

    Please consider upgrading to V15.5 and take advantage of the new web client that uses uaCSTA and can control a deskphone even if a phone is provisioned using STUN or is behind an SBC. You will need to run the latest supported firmware from 3CX and the latest templates.
     
  3. tvdir

    Joined:
    Feb 17, 2017
    Messages:
    55
    Likes Received:
    15
    Are the PC and T42G in the same VLAN? Is HTTP traffic allowed from the PC to the phone?
    Try to take a packet capture on the yealink while placing/answering a call using CTI, and check if you see the HTTP request coming from the PC.
     
Thread Status:
Not open for further replies.