T48G Auto Provisioning

Discussion in '3CX Phone System - General' started by Trever, Jan 17, 2017.

Thread Status:
Not open for further replies.
  1. Trever

    Joined:
    Jan 17, 2017
    Messages:
    5
    Likes Received:
    2
    Hello,

    We recently set up a 3CX install on an Intel Mini PC, install went great. Most things seem to be working fantastic, however we cannot get phones to Auto-provision. I must be missing something, we have tried a Fanvil C400 and a Yealink T48G, and they do not auto-provision even though they are supposed to be supported. Updated firmware and reset to factory as the guide said ti. When we assign an Ext, we get the page perfectly fine for the Ext, and then click okay after confirming the network is correct (Local network) but it never provisions automatically.

    What all should we have set up other than the phone server to auto-provision this?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Hello @Trever

    what you are doing sounds correct and from the description i understand that when you reset the phones you can see them appearing in the phones tab as New phones in bold and these are local extensions.
    Are you using an IP address for local Lan or did you specify a local FQDN?
    Try the following test and let me know if that works: Go to a different Pc on the network and type the provisioning link for a Yealink in the browser found under the phone provisioning tab followed by the MAC address of the phone and .cfg
    Example: http://192.168.0.1:5000/provisioning/xxxxxxxxxxx/macaddress.cfg
    This should download the config file for the phone. If you are able then the phones should also be able.
     
  3. MMDTerry

    Joined:
    Jan 11, 2017
    Messages:
    18
    Likes Received:
    2
    Is your provisioning link SSL? i had an issue where i had to manually use the non SSL link and port then everything worked fine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #3 MMDTerry, Jan 17, 2017
    Last edited: Jan 18, 2017
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    The internal provisioning link should be Http not Https. If the pbx is configured correctly then under the Phone provisioning tab in extension settings it should give you the http link for local lan provisioning automatically.
    Glad to hear it worked
     
  5. comnetcon

    Joined:
    Jul 20, 2011
    Messages:
    7
    Likes Received:
    0
    Also having some issues with provisioning. I tested the provisioning link from another computer and it downloads the config file. Initially the phones were showing up as "New" and I was able to provision some of them. Now, no matter what I try, the unprovisioned phones will not show up. Furthermore, some of those that were previously provisioned are no longer showing as registered. I'm able to ping the phones. Also noticed, after the fact, that when I was able to provision and assign an extension the UserID was not changing. All the phones provisioned with the same UserID. I went back into each extension and changed that. All phones are Yealink T48G. 3CX version 15.0.60903
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    The phones will appear as new in the 3CX management console only when they are in a factory reset state. Only then do they send multicast message. If that does not happen open a cmd and type "netsh interface ipv4 show joins"
    Your network card should be able to listen to 224.0.1.75. If you do not see this address in the list of addresses then you should give priority to your network card. Also check if the local IP of the PBX has changed or if there is any network issue (switch, router etc)
     
Thread Status:
Not open for further replies.