TAPI - Dial Phone not Softphone

Discussion in '3CX Phone System - General' started by DeepB, Jan 11, 2018.

Thread Status:
Not open for further replies.
  1. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    Hello,

    we use TAPI extensively, as our CRM-Software supports it.

    Unfortunately I can only install the TAPI-driver when the Softphone is installed. Which in iteself would not be a problem. But whenever I use TAPI to dial a number the Softphone calls the number, and not (how we are used to it, and how we need it) the desk-phone. (Yealink T48G if that is relevant).

    Any suggestions on how to achieve that?

    thanks
    Daniel
     
  2. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    38
    Hello @DeepB

    TAPI uses the softphone to dial out, but you can switch to CTI mode if you want to call out from the ip phone as shown below:
    upload_2018-1-11_10-49-1.png
     
    accentlogic likes this.
  3. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    perfect, that was the solution

    Another short question: Now TAPI dials on the phone, each digit, each with the same tone as if I would have input the digit by hand. Can this be faster and in quiet mode?`

    Thanks
    Daniel
     
  4. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    38
    Regarding the slow dialing, as a first step, make sure you are on the latest firmware and re-provision using the default template. Now for the dial tones, this is phone specific so maybe you could disable sound from Web UI of the phone or via a custom template.
     
  5. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    oh, sorry if I was not exact enough, I do not want to disable dialing tone in general. I do not want a dialing tone when dialing via TAPI.
     
  6. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    Oh, another problem I just found out: the 3cx Softphone has to run. And the CTI setting is not saved.

    Is there another option?

    There is no way I can have my users log on to the pc, open the softphone, change to CTI (as that setting seems to not be saved, and you have to set it again after each restart).

    Every other PBX I touched in the last 5 years handles this better.

    Thanks
    Daniel
     
  7. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    38
    In order for the softphone to start in CTI mode, you will need to change the Call Control Preference in the Extension Settings. Go to Extension Settings >> Provisioning Tab and under Preferences >> Call Control change the option to "IP Phone" and re-provision. This will force the client to start in CTI mode.
    As for the client, during the installation of 3CXPhone a shortcut is placed in C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp\ so it will automatically start when user logs in. If this is not happening, check in the above folder and make sure that there is a 3cx client shortcut in there.
     
  8. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    That is great help. However: most of my users have a deskphone and a DECT-phone.

    When I do what you suggested the 3CX client asks me on startup "you have multiple IP phones that support CTI[...]" and I need to pick one.

    So that is unfortunately also not really working.
     
  9. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    38
    Yes, In the case that you have two phones, the client will ask you to pick one to control. Unfortunately there is no way to avoid this. But TAPI driver will require 3CXPhone for Windows.
     
Thread Status:
Not open for further replies.