TAPI not working

Discussion in '3CX Phone System - General' started by DeepB, Feb 5, 2018.

Thread Status:
Not open for further replies.
  1. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    Hello,

    I have a problem with tapi.

    It is working as it should with our desk phones (Yealink T48G). However it is not working at all with our dect phones. (Gigaset SL750H pro).

    I guess that is because 3cx dials on the phone itself, which it might not be able to do on the gigaset handsets?

    any ideas?

    thanks
    Daniel
     
  2. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    Anyone? this really is a problem....

    thanks
    Daniel
     
  3. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,199
    Likes Received:
    79
    if you see MakeCall in the display, then this call is disconnected from any callprocessing and the tapi will not see the call as the way we need to "invite" the device to a call" is a fake, we call it, hold it, dial desintation, on answer transfer. Imagine how that will look in the tapi logs...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. DeepB

    Joined:
    Jan 4, 2018
    Messages:
    26
    Likes Received:
    0
    I am not sure I understand.

    How TAPI-dialling worked on the old pbx (that was bought by 3cx): pbx called caller, pbx called recipient. End-point agnostic

    I now have around 30 users that use gigaset dect-handsets and need tapi-dialling. How do I make that happen in 3cx?

    thanks
    Daniel
     
Thread Status:
Not open for further replies.