Solved Testing 3cx - Provisioning Polycom IP450

Discussion in '3CX Phone System - General' started by andrewm30, Jun 15, 2017.

Thread Status:
Not open for further replies.
  1. andrewm30

    Joined:
    Jun 15, 2017
    Messages:
    15
    Likes Received:
    0
    Hello,

    I'm testing 3cx right now, liking it so far.

    I have all ports forwarded correctly. I can make calls, including remote 3cx soft phone clients without issue using the sbc, windows environment.

    I'm attempting to remotely provision a polycom device for testing. I setup option 66 in my DHCP server and it correctly resolves my outside IP for my windows 3cx box.

    It doesn't appear that 3cx is provisioning the polycom phones correctly. I put the firmware files for the IP450 in programdata\3cx\instance1\data\http\inter\provisioning\<numbers>\<root with firmware>

    What I notice, is for the phone I'm testing, I only have a <mac of polycom-directory.cfg. There is not a <macaddr>.cfg file listed. I searched my PC for it, and I can't find it anywhere and that coincides with the error i'm getting on the phone : Unable to download <mac>.cfg, using existing config.

    I have a freepbx box with tons of extensions, so I'm fairly familiar with provisioning these types of phones..

    I'm getting a access denied 403 error on HTTP when attempting to browse to it, but again, the config file for the phone doesn't seem to exist.

    I've tried recreating the extension and it's still not generating any kind of config that I can see..but I'm new to the system

    What am I missing or what should I try? I'm pretty sure I'm going to have this same issue locally when I try it tonight.

    Thanks.
     
  2. Saqqara

    Saqqara Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,155
    Likes Received:
    176
  3. andrewm30

    Joined:
    Jun 15, 2017
    Messages:
    15
    Likes Received:
    0
    So I need to use a VPN in order to configure it remotely?

    What about the issue of the config file not being in the directory? shouldnt there be a <mac>.cfg somewhere that matches the phone?
     
  4. Saqqara

    Saqqara Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,155
    Likes Received:
    176
  5. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    OK I will explain. You are right.. You know you should have more files there for Polycom.
    But with 3CX dont expect the file to be there. The file is generated on request so if the phone or entity did not GET this from Webserver, then file is not generated.
    And if you GET a file and it is OKayed, the file will physically still not be present. You won't see it.

    Now polycom.. these are LAN only for now. If you want wan you need to put SBC. Its like a vpn in concept. Actually it is a VOIP Tunnel made by us. Its easy and you have windows, debian and raspberry pi options.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. andrewm30

    Joined:
    Jun 15, 2017
    Messages:
    15
    Likes Received:
    0
    Nick,

    Thank you for the reply.

    I have the SBC installed, and looking at extensions here in my office that are connecting via the 3cx windows client remotely, it shows, under phones in the web config..both the WAN IP here at my office, and the local lan with provision next to it, so I'm assuming the SBC is working, is there another way to check this in the webconfig I missed or do i need to wireshark it?

    The DHCP option 66 scope is working on the polycom phone, as it pulls my remote offices public IP for the provisioning server on boot, but again, gives the error that the .cfg for the mac address doesnt exist..so, is the request not getting to my remote box, therefore not generating he config file or could it be something else? I would assume, as dealing with other phone systems, when the phone cannot get to the server to request the firmware it usually says that it can't be contacted, not that it couldn't download.

    Port 5000 forward is working properly, its an open port.

    When browsing to my machine via HTTP with IP/FQDN and path with port 5000 specified., I am getting a 403 access denied I suspect this is the issue. The port is forwarded, I need to look into this more
     
  7. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    So you have communication. More details show me more things we can do.
    Make the polycom request the config via https. http traffic is blocked from outside.
    There is a way. Set it to be the default provisioning method before hand and then start.
    Try it..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. andrewm30

    Joined:
    Jun 15, 2017
    Messages:
    15
    Likes Received:
    0
    I was able to get the phone to provision locally by forcing the provisioning url through the phone itself, and it worked without issue.

    Question - once it pulled the config for the polycom phones, it changed the default admin password for the web gui, which I need to get into in order to setup the proxy for the SBC IP to test remotely. I looked through the polycom config template, and I didn't see it listed. I can get in as user but, unable to make any changes obviously to the lines...

    What does the 3cx polycom config set the admin user password to?(you also cant change it in the phone gui.)

    Its not 123, 456, 222222, 111111..typically 456 is the default, but it isn't. I may of just overlooked it in the config

    Thanks!
     
  9. Saqqara

    Saqqara Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,155
    Likes Received:
    176
    Web password is under Extension - edit the extension , click phone provisioning tab, and you will see 'Phone Web Page Password' - click on the icon to the right
     
    andrewm30 likes this.
  10. andrewm30

    Joined:
    Jun 15, 2017
    Messages:
    15
    Likes Received:
    0
    THank you, can't believe I missed this!
     
Thread Status:
Not open for further replies.