Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Trouble updating 3CX from 15.0.60903.0 to 15.0.62928.5

Discussion in '3CX Phone System - General' started by Jono, Jul 17, 2017.

Thread Status:
Not open for further replies.
  1. Jono

    Joined:
    Jun 29, 2013
    Messages:
    27
    Likes Received:
    0
    When I try to do the update from the console, I get the expected warning screen that says "The 3CX services need to be stopped during the update. Management Console will be unavailable during this time. An email will be sent to the Admin after the update is complete. Do you want to proceed with the update?"

    I click the OK button and I get the banner that says "Download updates... Download has started, please wait" but it doesn't move past that. I had t running all weekend, but it still says the same thing.

    What I've done so far with no change in results:
    • I tried turning off the anti-virus and the Windows firewall.
    • I have rebooted the server.
    • I successfully downloaded and updated phone firmware from the same interface.
    • I have tried the update from the server itself and from a client.
    • I am able to get to downloads.3cx.com (blank page with "I am here eu" on the tab).
    If anyone has any advice on what else I can try, I'd appreciate it. I would eventually like to get it up to the current version (15.5, I believe), but I suppose I need to work my way to that being available in the interface, is that right?

    Thanks for your help.

    Jono
     
  2. GiannosC_3CX

    GiannosC_3CX Guest

    hello jono,

    I have sent you a P.M please check your inbox.
     
    Jono likes this.
  3. Jono

    Joined:
    Jun 29, 2013
    Messages:
    27
    Likes Received:
    0
    Here's the results of this thread in case it will help anyone, but I'm not sure there's a lot to say.

    GiannocC_3CX asked me to do a Wireshark trace. After the Wireshark install a reboot was required. I did the reboot that was required by the Wireshark installation. When the server came back up, I got an email stating that an update failed. I never received an email like that before, so I tried the update again and it worked perfectly! I got the expected "success" email and then immediately another email stating that another update was necessary. That second update was also successful and now I'm on v15.5.5! I never even started Wireshark.

    Bottom line in this case was: Do another server reboot.

    I hope this helps others.
     
  4. GiannosC_3CX

    GiannosC_3CX Guest

    Hello,

    Glad to hear the issue is resolved Jono and thanks for update the post :)
     
Thread Status:
Not open for further replies.