Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Trouble wiht external extension

Discussion in '3CX Phone System - General' started by hoosier1077, Mar 8, 2011.

Thread Status:
Not open for further replies.
  1. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Hello,
    I have a 3cx server all setup in my office with a voip provider, and everything is working great. I tried to test out the external extension with a Linksys SPA921. I have configured my office firewall that sit in front of the 3cx server exactly as instructed, and have a static public ip and port mapping completed as well as instructed. I am not using a stun server because I believe I read in many posts that if you have a static public ip, you should turn stun off. So I take the external extension home and set it up on the sip manger with my public ip. My router at home is a simple dlink router that has not firewall, nothing else using the viop/sip ports that are required for 3cx to function. At home I do not have a static public ip, so ive tried configuring the phone with and without stun server. Both ways I am able to call out and receive, however I have not outbound audio. Anything I say into my spa921, cannot be heard on the other end. I can hear them just fine though. The router also has a simple “sip” check box within the setup, not sure what its for, but it is checked. I have also tried unchecking it but got same result. Any help would really be appreciated. Thanks.
     
  2. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Remote extension should not need any port mapping. On the phone itself, make sure you actually use STUN, on those phones follow carefully the setup especially enable NAT and NAT keep alives plus the VIA settings. Again, on the remote location router do not setup anything static and do not enable any SIP helper/ALG. Make sure you are using a newer firmware (at least matching the tested one from 3CX). This works every time.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Thanks for getting back to me, I appreciate it. I have just upgraded the firmware to the newest the have, which is what 3cx has on its site as tested. I have also turned on stun, using stun.3cx.com as the server. There is another option next to that where it asks for ext. ip. Its a part of the stun server options, and Ive just been leaving it blank. Would you know if I need to put the public ip of my remote location, or maybe the 3cx server location in that spot? I have looked an a few setup online for this particular phone, and will continue to do so. However I just havent had luck with this one way audio yet. Thanks again.
     
  4. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Also... Just wanted to include this if it helps. In the prox and registration area, I have the public ip of my 3cx server in the "proxy" field, and have nothing in the "outbound proxy" feild. As well as use outbound proxy set to no. Maybe you can see something wrong in that config, thanks again.
     
  5. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    I find this works best with the spa9xx series.

    Proxy: internalipaddressof3cx:port (usually 5060)
    Use Outbound Proxy: Yes
    Outbund Proxy publicipof3cx:port

    All other settings can stay the same.

    Also make sure you use the AuthID and set UseAuthID set to yet.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    OK, that has been done. I feel like we are getting close. Just to double check the "nat supported parameters" area. This is where my stun setup is on the phone. I currently have stun enabled, stun server "stun.3cx.com" (which im thinking maybe isnt what Im supposed to have in there), I have nothing in the "ext ip" box next to stun server box. I guess since im not using stun on my 3cx server, im not really sure what to put in this section....
     
  7. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    If you have a static PUBLIC IP on the 3CX server side, do not EVER enable STUN on the server. Use your STATIC public IP. Do not do the Private/public IP Proxy setup cited above. This is not the way it is designed to work. You can and must enable STUN on the remote phone regardless if that is setup onthe server. STUN is a function that makes the phone and then the server aware of your remote phone public IP and the ports to use. If you need help configuring the phone, PM me and we can setup a remote session and get you up and running.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    OK I led you astray with the Proxy - i didnt read carefully and you had already registered.

    You can put it back with the pubic ip as the proxy and no use outbound proxy and leave it blank.

    Make sure you have Nat Mapping Enable = yes and Nat keep alive Enable = yes on the top of that Extn Page.

    On the NAT Support Parameters.

    You need to change Handle Via rPort to yes and Insert Via Rport to Yes.

    Stun enable = yes. stun.3cx.com and NAT Keep Alive Int to 15
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    OFF TOPIC - EDITED BY MFM

    3CX posted a terrific guide at: http://www.3cx.com/sip-phones/ Updated link (works on your linksys too). Simply follow that.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Well thanks for the help, Ive tried it every which way and still no outbound audio from the remote spa921. I used the cisco phone setup that you sent me and made those changes, and used the 3cx server public ip as the proxy, no outbound proxy and put the stun.3cx.com in the stun server area of the config, but still just cant get it to work properly. If you have anymore ideas I would appreciate the help. Thanks.
     
  11. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    The next item to review is your router at the remote location. What router are you using? Brand/Model

    Ensure that SPI firewall is turned off
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Ive got one of those dlink "gamer" wireless N gigabit routers, whith SPI turned off. I ran across one thing that I didnt configure on my server end when setting up the static port mapping. Its from the 3cx site....

    •name==”TCP::5060″, protocol==”TCP”, port_from==”5060″, port_to==”5060″
    •name==”UDP::5060″, protocol==”UDP”, port_from==”5060″, port_to==”5060″
    •name==”TCP::5090″, protocol==”TCP”, port_from==”5090″, port_to==”5090″
    •name==”UDP::5090″, protocol==”UDP”, port_from==”5090″, port_to==”5090″
    •name==”UDP::9000-9049″, protocol==”UDP”, port_from==”9000″, port_to==”9049″
    •name==”UDP::10000-10049″, protocol==”UDP”, port_from==”10000″, port_to==”10049

    I setup everything execpt that last line because I dont remember ever seeing that required or explained in the tutorials. If its not important I wont worry about it.
     
  13. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Also... Is there any special way the extension needs to be setup on the 3cx end? Can it be the 100 (main)ext? Ive got ext 100 setup as a normal extension, I havent run across anything telling me that an extension used remotely needs to be setup differently on the 3cx server....
     
  14. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Hoosier, please do not setup any port forwarding at the remote site. Gaming router is a great choice. Remove anyt and all port mappings on it, make sure that you setup in the firewall rules, Endpoint independant (twice in teh same page). Enable gaming mode (if you have an option for that, not knowing the exact model I can't be specific but some have this as a checkbox). Enable ALG s (all, PPTP, SIP etc). Then retry. If you can get me exact model number it would help. Please know that D-Link had some SIP issues with older firmware, upgrade to the latest if possible.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Just trying to make thing a little easier... I am taking the spa921 out of the equation and using 3cx softphone. I get same result. When I have the softphone running on my remote pc, and I enable my vpn tunnel into my office network, the audio work just fine both ways. I use the 3cx server private IP ofcourse since the vpn is established. However when I take that vpn away, and go back to using 3cx server public IP I get the one way audio. If your stumped I understand, I still appreciate the help so far.
     
  16. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    I'll give that a try now....
     
  17. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    OK, Let's go back to the beginning.

    Site A has your 3CX server - The router there has the following ports pointed to it:
    5060 UDP and 9000 to 9050 UDP
    You can do 5481 TCP to remotely manage the server is you use Abyss/Cassini or 80 for IIS
    5090 TCP and UDP to use the 3CX tunnel (take a moment to set a password for the tunnel)

    Site B is your remote location, you did not FWD any ports

    3CX Phone at site B registers fine (GOOD)
    3CX Phone at site B does not register (have you used the proper password? not the VM one but the Alphanumeric one aka comlpicated one)

    MAKE 100% sure that ports 9000-9050 UDP is configured on the server at site A!!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    I took a look again at server end and everything looks good. Only difference is my original instruction had me setup udp 9000-9049 instead of 9050. Im not port forwarding anything at the remote end, and even though my spi is turned off, i notice that im getting this error on remote side....

    SIP ALG rejected packet from serverendpublic:5060 to remoteendpublic:49485

    Im not sure if that has anything to do with it or not. I did upgrade the firmware to newest they had, went back through and made sure spi off, sip, rstp, etc.. was checked. Gamefuel is turned on and endpoint independent are chose on both. its a dgl4500 model on that dlink router.
     
  19. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Also, here is the log from remote router just after making call that connects just fine but again no outbound audio... is it possible my isp is blocking this kind of traffic i need to make this work....


    [INFO] Sat Jan 31 11:01:09 2004 Blocked outgoing ICMP packet (ICMP type 3) from (remote phone lan ip) to (3cx server public)
    [INFO] Sat Jan 31 11:01:07 2004 Above message repeated 103 times
    [INFO] Sat Jan 31 11:01:07 2004 SIP ALG rejected packet from (remote phone lan ip):16519 to (private 3cx server ip):7042
    [INFO] Sat Jan 31 11:01:03 2004 Above message repeated 241 times
    [INFO] Sat Jan 31 11:01:03 2004 Blocked incoming ICMP packet (ICMP type 8) from (att modem IP) to (remote public IP)[INFO] Sat Jan 31 11:01:03 2004 SIP ALG rejected packet from (remote phone lan ip):16519 to (private 3cx server ip):7042
    [INFO] Sat Jan 31 11:01:01 2004 Above message repeated 52 times
    [INFO] Sat Jan 31 11:00:51 2004 SIP ALG rejected packet from (remote phone lan ip):5060 to 96.9.132.83:3478 (no idea what ip address this one is.
     
  20. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Disable the ALG and see if it changes anything. (SIP)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.