Trunk/Provider responds to Request with an error

Discussion in '3CX Phone System - General' started by JCLloyd, Nov 16, 2017.

Thread Status:
Not open for further replies.
  1. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    112
    Likes Received:
    19
    It appears that I am letting the PBX send internal call information through the SIP to the provider. If I call an internal extension, including the 9999 voice mail number, I get a 3CX email back with an error. I don't want to deselect the "Trunk/Provider responds to Request with an Error code" email selection but reduce the amount of errors I send to them.

    I thought it might be that I didn't define "Calls to Numbers with a length of", but when I entered "7,10,11", the error went from:
    . 484 Address Incomplete
    to:
    . 403 From: URI not recognized

    I saw this in a few other threads that were already closed for comments, and the ones that had a response were suggesting to deselect the "Trunk/Provider responds to Request with an Error code" email button.

    I'd like to not send internal extensions and the voicemail code to the SIP. I'll keep trying things, and will respond if I do figure it out, myself. Any suggestions are greatly appreciated!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,754
    Likes Received:
    286
    If call are unintentionally routing to your provider, then, from the sounds of it. you have not set up your outbound rules correctly. That said, if there is an extension number that matches a dialled number, the call should be recognised as local, and not proceed to the outbound rules.

    https://www.3cx.com/blog/voip-howto/outbound-rules-a-complete-example/
     
    apostolis_3CX likes this.
  3. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    112
    Likes Received:
    19
    Leejor, thank you for the fast reply. It looks like setting the "Calls to Numbers with a length of" setting to "7,10-11" took care of the 484 error.

    I found this recent 3CX forum thread where someone had to enter the SIP provider's FQDN along with their IP address. I may be in the same situation. I'll check it, later in the day, and post if it works.
    https://www.3cx.com/community/threa...t-recognized-from-ip-208-68-17-52-5060.51173/



     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    112
    Likes Received:
    19
    I am working without a repeat issue, and I am not sure why... I tried several times to repeat the 403 URI error, without success. The SIP provider didn't detect any traffic leaking when I did some 4-digit extension dialing tests, so maybe I had fixed the issue and just saw latent emails.

    There may be some other intermittent thing happening. I did see a 6-year-old TechNet thread where someone had a firewall issue not properly defining both TCP & UDP for port 5060, but that affected all inbound traffic. Maybe, the router we are on has some periodic port translation issue. I did get a few ports that rolled 5060 to alternate ports when I was first installing the software and running the Firewall Check. There error never repeated, but maybe the router has some 'quirk'... RV320, if anyone has any knowledge.

    Thanks for being there. Maybe, this thread will help someone else...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    112
    Likes Received:
    19
    Everything is OK, today... Here is my guess...

    Since I have set the Outbound Rule's "Calls to Numbers with a length of" to "7,10-11", I don't seem to be getting blocked from internal calls with the 3CX apparently rejecting calls from the SIP.
    My guess is that by leaving the "Calls to Numbers with a length of" setting blank, I was allowing all dialing to go out to the SIP. That condition would return errors that sent me email alerts. When a had two or three people using the PBX and generating a lot of these errors, the 3CX would eventually blacklist the SIP provider IP address.

    Since I did not keep clear notes on what the SIP provider mentioned, and I did not think to check the black list before restoring to a last known good state... Does this sound viable? Would it be worth setting a permanent white list for the SIP provider IP address?

    Thank you, everyone... I have had an enjoyable time learning the software based PBX. I have a ways to go, but feel pretty good with how I have progressed.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Glad to hear the issue is resolved and thank you for sharing your solution however the PBX will never try going out the Voip provider if the called dialled matches an internal extension. The PBX first checks extension number and then proceeds to the Outbound rules. What was the extension length the PBX was installed with? Did that change?
    You could revert to the original configuration that caused the problem and run a wireshark capture. That will indicate if the PBX is trying to contact the provider during local calls.
     
Thread Status:
Not open for further replies.