Trying to add SIP URI Parameter

Discussion in '3CX Phone System - General' started by Kobberhjelmen, Aug 14, 2017.

Thread Status:
Not open for further replies.
  1. Kobberhjelmen

    Joined:
    Aug 1, 2017
    Messages:
    11
    Likes Received:
    2
    Hi
    I have a sip provider that requires an URI Parameter of "user=phone".
    I'm trying to add this by setting the outbound "Request Line URI : Host Part" to Custom Field variable, and adding the following Custom Value: "IP:5060;user=phone" - But the part after ; gets ignored, and isn't in my wireshark capture.
    Is it not possible to create/add a SIP URI parameter in 3CX?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    Is anything other than user=phone actually required?
     
  3. Kobberhjelmen

    Joined:
    Aug 1, 2017
    Messages:
    11
    Likes Received:
    2
    IP+Port is needed, user=phone is a "secondary" parameter, but at this particular provider it is required
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    I came across this.

    https://www.voip-info.org/wiki-sip+uri

    It mentions the use of the @ , and the correct format.

    I'm not certain it is what you are looking for. Just sounds like the information you are putting in, may be more that can be accommodated, and therefore ignored, or in the wrong format.
     
    #4 leejor, Aug 15, 2017
    Last edited: Aug 15, 2017
  5. Kobberhjelmen

    Joined:
    Aug 1, 2017
    Messages:
    11
    Likes Received:
    2
    before @ is the user part (number), after @ is the host part (server+port), i need to add the uri parameter to the host part - This is normally done by putting semicolon+"uri-parameter" (;user=phone in this case), but perhaps i need a different syntax for 3CX, since it is getting ignored.
    But i cant find anywhere if they support, or doesn't support uri-parameters, so that could also be the reason.
    If a create a CustomField with a Custom value, i can put in user=phone as the only value, and the entire uri turns in to: sip:number@user=phone:5060.
    If i makes the custom value 1.2.3.4:5065 (Different host ip+port) it turns in to sip:number@1.2.3.4:5065
    If i makes the custom value 1.2.3.4:5065;user=phone it turns in to sip:number@1.2.3.4:5065

    Thats why i think 3CX either doesn't support uri-parameters,or i need a different syntax than ; to activate it
     
Thread Status:
Not open for further replies.