Trying to get Remote Extensions Working

Discussion in '3CX Phone System - General' started by warever, Jul 15, 2015.

Thread Status:
Not open for further replies.
  1. warever

    Joined:
    Oct 19, 2008
    Messages:
    12
    Likes Received:
    0
    I'm a 3CX partner, and am trying to do a demo for a client. I've got the demo 3CX version 12.5 running on a server in my datacenter. Static IP with 1:1 NAT on the Sophos UTM, ports 80, 443, 5060-5061, 5060 UDP, 5000-5001, and 9000-9199 open inbound.

    At the client site, they've got AT&T DSL (blech) with their modem/router and a Netgear FVS-318G behind it. I've got two Cisco SPA504G phones there.

    At first, I got one phone to register but the other wouldn't. They both showed as registered (green button), but 3CX showed only one as registered and you'd get a "not found" calling that extension. Fiddled around a bit, rebooted everything, and after a while, the other one worked but the first one didn't.

    A couple of days later, both were connected just fine, I could call both, etc.

    Today - another couple of days later - neither would register. I tried just about everything.

    The phones are set to use stun.3cx.com, and then I tried stun2.3cx.com. BTW, I manually configured them (not provisioned from a template). They're set up almost exactly the same as my SPA962 on my own desk which connects just fine (I set up an extension to their 3CX).

    I also have the 3CX v12 phone app on my iPhone 6 configured as an extension (not using the tunnel). When I connect from within my office, it works fine. When I use Verizon LTE, it works fine. When I use the client's WiFi, it doesn't work.

    Anyone got any ideas? I'm very frustrated, and the fact that I can't get the demo to work in the client's own office makes me look like an idiot - and doesn't bode well for trying to sell him 3CX (a pretty decent sized system with 20 remote reps and three separate offices).
     
  2. Charles_3CX

    Charles_3CX New Member
    3CX Support

    Joined:
    Jul 6, 2015
    Messages:
    114
    Likes Received:
    4
    Hi Warever. Sorry to hear about your problem. Sorry to state the obvious but, Did you run the firewall checker on the 3CX Phone System? You may also want to disable SSL certificates on the actual Cisco handsets. See this guide which may also help you make sure that you have covered all your bases: http://www.3cx.com/sip-phones/cisco-spa/. If all else fails please open a support ticket with us in order to take at look at this issue with you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,848
    Likes Received:
    299
    You did assign a different local port to each of the devices?
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,401
    Likes Received:
    273
    I think Leejor hit it on the head. or use an SBC.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.