Twilio Elastic SIP Trunking with 3CX - One-Way Audio & No Outbound Calls

Discussion in '3CX Phone System - General' started by blue24, May 5, 2017.

Thread Status:
Not open for further replies.
  1. blue24

    Joined:
    Sep 19, 2014
    Messages:
    2
    Likes Received:
    0
    I cannot get Twilio Elastic SIP Trunking to work as a SIP provider for my 3CX install (v15, linux).

    I have 3CX setup and working with Flowroute and it has been working fine for over a year. We want to move our SIP trunking to Twilio Elastic SIP Trunking, because of the price and the extensive development platform. I have been following the guide here: https://www.twilio.com/resources/images/docs/3CX-Twilio.pdf

    I can receive inbound calls but run into 2 issues:
    1. Calls inbound only have one-way audio. I can hear the caller but the caller cannot hear me.
    2. Outbound calls result in "403 Forbidden" when using just IP Based Authentication and "Destination is not reachable" when using Account Based Authentication.

    Thanks in advance!
     
  2. Panayiotis_3CX

    Panayiotis_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Apr 26, 2017
    Messages:
    165
    Likes Received:
    7
    Hello @blue24,

    Did you run the Firewall checker and received no errors? What ports did you use? Is your IP static?
     
  3. blue24

    Joined:
    Sep 19, 2014
    Messages:
    2
    Likes Received:
    0
    The firewall check runs without issue. We are using the default ports. Yes, our IP is static.
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Next step is performing a wireshark capture on the PBX machine while trying to make a call. Wireshark will give you a pretty good idea where the error is coming from. I would also review the Twilio settings and make sure everything is setup correctly.
     
  5. Yury Rabinovich

    Joined:
    Apr 13, 2017
    Messages:
    9
    Likes Received:
    2
    For the 403 denied error, using IP based authentication, you need to add your PBX ip/port to the origination URI list on the Twilio side.
     
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Yes we are a bit disadvantaged because we know 3CX, but we dont know the twilio portal.
    I think in parallel, if I were you, I would send on the forums of 3CX (as you did) but also in sync send some emails to Twilio or check how to configure Twilio with asterisk for example. This is the way to go when you are working with a provider which is not supported.
    Investigate the portal and post screenshots.. For sure if you get 403 and this 403 is coming from Twilio, then something Twilio does not like. This is the beauty of working with supported providers because we would know their settings.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. loyer

    Joined:
    May 5, 2016
    Messages:
    42
    Likes Received:
    4
    Hi blue24, did you ever get your Twilio trunk working? Was the problem a firewall issue or settings on Twilio?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,252
    Likes Received:
    63
Thread Status:
Not open for further replies.