Solved unable to activate maintenance license

Discussion in '3CX Phone System - General' started by coreybrett81, Oct 25, 2017.

Thread Status:
Not open for further replies.
  1. coreybrett81

    Joined:
    Nov 11, 2016
    Messages:
    35
    Likes Received:
    7
    I purchased a maintenance license for the PBX edition, but I am unable to activate it.

    When I click on the License option under the Settings menu, I see "license_error." in the Licence status row.

    If I click Edit, then fill out the Customer details and click OK, I get "license_error.HttpsError".

    Does anyone know how to activate a maintenance license?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,408
    Likes Received:
    282
    Hello @coreybrett81

    This usually indicates and error with your DNS settings. Please make sure that you can resolve activation.3cx.com and erp.3cx.com from the PBX server correctly. Also is this a windows or linux setup and what version are you running?
     
  3. coreybrett81

    Joined:
    Nov 11, 2016
    Messages:
    35
    Likes Received:
    7
    cboyle@mars:~$ host activation.3cx.com
    activation.3cx.com has address 151.80.125.88
    cboyle@mars:~$ host erp.3cx.com
    erp.3cx.com has address 151.80.125.67
    cboyle@mars:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 8.9 (jessie)
    Release: 8.9
    Codename: jessie
    cboyle@mars:~$ dpkg -l \*3cx\*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-====================-===============-===============-=============================================
    ii 3cxpbx 15.5.3849.1 amd64 3CX PBX
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,408
    Likes Received:
    282
    Try setting google DNS 8.8.8.8 as your primary DNS and restart services including the Nginx service and try activating it again.
     
  5. coreybrett81

    Joined:
    Nov 11, 2016
    Messages:
    35
    Likes Received:
    7
    That did the trick!

    I'm not really sure why because, activation.3cx.com & erp.3cx.com still resolve to the same address.
    The default DNS on our network is OpenDNS.

    Thank you for the help.
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,408
    Likes Received:
    282
    Glad to hear the issue is resolved
     
Thread Status:
Not open for further replies.