Unable to contact STUN

Discussion in 'Windows' started by firstprotect, Feb 16, 2012.

Thread Status:
Not open for further replies.
  1. firstprotect

    Joined:
    Feb 16, 2012
    Messages:
    2
    Likes Received:
    0
    I'm trying to use 3cx phone on a Windows Vista machine, and I'm getting a STUN check fail (trying to connect to a variety of servers):

    DX:MP3 Writer initialized
    DX:MP3 Encoder initialized
    DX:FFDShow not present
    Translation file OK
    Attempting to connect voip1.noblesolutions.co.uk
    Phone got as local port 64500
    Jabra not connected
    RTP engine OK
    SIP engine OK
    Sound mic device OK []
    Sound ring device OK []
    Sound speaker device OK []
    Sending STUN request
    STUN check failed
    STUN check failed
    STUN check failed
    STUN check failed
    STUN check failed
    STUN check failed
    Unable to contact STUN

    ---
    Can anyone explain what the problem might be, or how I can troubleshoot it? My configuration is as follows (I've removed the login details):


    [Profile0]
    Name=***
    Enabled=1
    CallerID=***
    AuthUser=***
    AuthID=***
    AuthPass=***
    PBXAddr=voip1.noblesolutions.co.uk
    PBXRemoteAddr=voip1.noblesolutions.co.uk
    PBXVoicemail=
    ServerProxy=
    DtmfRFC2833=1
    DtmfInband=0
    DtmfSipinfo=0
    DtmfPayload=101
    SipTransport=0
    RegistrationTime=2
    Codecs=PCMU;PCMA;GSM
    VideoCodecs=H.263 (ffdshow)
    VideoFormats=QCIF;CIF;SQCIF;CIF4;
    LocalPBX=0
    RTPTransport=0
    ProvisioningURL=http://
    UseTunnel=0
    UseProxy=0
    TunnelPass=abc
    TunnelRemAddr=voip1.noblesolutions.co.uk
    TunnelPort=5090
    PBXPort=0
    STUNServer=
    AutoProvisioning=0
    VoicemailConfirmed=0
    CLSID={B3C77091-AEFC-4F33-A9AC-F483A3ACE394}
    [General]
    VideoCamera=
    VideoAutoSend=1
    VideoSendWhenInactive=1
    UseVideo=1
    EchoCancellation=0
    NoiseReduction=0
    ActiveBLFBank=0
    SndMicGUID=
    SndPlayGUID=
    SndRingGUID=
    Skin=3CXPhone.cxs
    ActiveProfile={B3C77091-AEFC-4F33-A9AC-F483A3ACE394}
    RunAtWinStartup=0
    ShowDebugWindow=0
    LangFile=
    MACAddress=912D8D082649
    SipTraceLog=0
    LocalRecording=0
    MP3Recording=0
    TunnelLog=0
    ExpandPlus=1
    NoFocusSteal=0
    OnComputerLocked=0
    OnScreensaverStarts=0
    SpeakerVol=0
    RingingVol=0
    MicVol=0
    xpos=1002
    ypos=208
    Brightness=-22
    Contrast=133
    Saturation=108
    Sharpness=25
    RTPFirstPort=40000
    RTPLastPort=40049
    LocalPort=-1
    AmPmClock=0
    CheckUpdates=1
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,355
    Likes Received:
    223
    I just see...

    No server information
     
  3. firstprotect

    Joined:
    Feb 16, 2012
    Messages:
    2
    Likes Received:
    0
    Thanks for your reply, leejor.

    I must have copied the config file while attempting to remove the STUN server check. I have double checked and now the STUN server config says:

    STUNServer=stun.3cx.com

    I still get the same issue. Incidentally, I only get the issue on one particular machine and it shares an office with other machines that work fine. Are there any other routes I can take to troubleshoot this issue?

    Thanks in advance
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,355
    Likes Received:
    223
    If you just have the issue on the one machine, then, I'm going to hazard a guess that something is not set-up properly on that machine. Perhaps the network or firewall settings. Do you use something like Zonealarm or Norton that needs to be "opened" to the 3CX phone programme?

    If you can do a Ping to outside sites (URL's), then you are connecting to a DNS server properly.

    And remember, you don't have to use the 3CX STUN server, if you do a web search, you will find many available to you.
     
Thread Status:
Not open for further replies.