unable to install on Google cloud

Discussion in '3CX Phone System - General' started by nickloenders, Oct 20, 2016.

Thread Status:
Not open for further replies.
  1. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Hi,

    all seems to install well on Google Cloud, but then this appears:

    Waiting for 0 seconds, press CTRL+C to quit ...
    Checking if 3CX is responding in VM: nicklhome3cx-v15
    (UNKNOWN) [104.132.11.120] 5015 (?): TIMEDOUT
    3CX is not yet responding.
    waiting for 5 seconds

    And it does not stop anymore

    Anyone else had this problem?
     
  2. superior1

    Joined:
    Apr 11, 2011
    Messages:
    34
    Likes Received:
    1
    Nick,

    I am having this same issue. Did you ever get it resolved?
     
  3. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Hi,

    I reinstalled it using the manual way and via SSH do it codeline by codeline.
     
  4. superior1

    Joined:
    Apr 11, 2011
    Messages:
    34
    Likes Received:
    1
    Is there instructions doing that way? If so send me the link. Thanks
     
  5. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    You can follow the instructions, how to install in on Linux.

    So first make the instance on Google Cloud and then connect to it, so you have the ssh (puty) window.
    Next use the Linux installation (manual) guide.
     
  6. nickloenders

    Joined:
    Oct 10, 2016
    Messages:
    34
    Likes Received:
    2
    Did it work?
     
  7. superior1

    Joined:
    Apr 11, 2011
    Messages:
    34
    Likes Received:
    1
    Yes. I got it installed. Thanks
     
  8. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    I have successfully installed 3CX V15 on Google Cloud. I have sucessfully connected a trunk.
    Now I have the problem to connect Telefon (Yealink T41, 3CX Softphone) to the extension.
    I tried to enter the profision link from the yealink telephone. But it does not register.

    I checked the ports:
    C:\Program Files (x86)\Google\Cloud SDK>gcloud compute firewall-rules list

    default-allow-icmp default 0.0.0.0/0 icmp
    default-allow-internal default 10.128.0.0/9 tcp:0-65535,udp:0-65535,icmp
    default-allow-rdp default 0.0.0.0/0 tcp:3389
    default-allow-ssh default 0.0.0.0/0 tcp:22
    pbxports default 0.0.0.0/0 tcp:5001,tcp:5090,udp:5090,tcp:5060,udp:5060,tcp:5061,udp:9000-9500,tcp:5015,tcp:443

    I entered Server host: xxx.3cx.eu Port 5060 UDP in Yealink 42 phone, but register failed.
    As well with the Softphone I tried same with no success (In Office an Out of office is xxx.3cx.eu)
    Do I need to use the tunnel.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. JonnyM

    Joined:
    May 17, 2010
    Messages:
    81
    Likes Received:
    5
    Is the extension allowed to register from outside the LAN?
     
  10. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    Extension-->Option-->"Register outside LAN not allowed"

    Is NOT tagged

    registration is still not working
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. superior1

    Joined:
    Apr 11, 2011
    Messages:
    34
    Likes Received:
    1
    Make sure that the IP address is not black listed

    Are you using stun or SBC?
     
  12. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    I think IP is not blacklistet (where can I check?). I can enter the 3CX-Console: https://xxx.3cx.eu
    I am using STUN.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. superior1

    Joined:
    Apr 11, 2011
    Messages:
    34
    Likes Received:
    1
    on the dashboard screen there is a blue box that says "IP Blacklist"

    Check there
     
  14. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    There is no entry in the blacklist.

    The only entry is "Webmeeting Servers" in the whitelist. Now I added my Router IP to the whitelist.

    But still no access.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    Any suggestions?

    I still wait to connect my extensions to 3CX at Google Cloud
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    Once again:
    1. I installed 3CX on Google Cloud as explained on 3cx webpage.
    2. I can enter the dashboard sucessfully
    3. I connected a trunk sucessfully
    4. BUT I can not connect to Extension.

    Can someone help me with a step by step example.

    Thank you
    Matthias
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Try going into the phones web interface/security/trusted certificates and disable the option only accept trusted certificates and try provisioning the phone by copying the link into the phones web interface and see if that works
     
    Milton Schreiber likes this.
  18. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    It runs now! Thank you!

    How can I confiure 3CX Softphone?

    Regards Matthias
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Great glad to hear it is working,

    Have you tried provisioning the 3cx client with a welcome email? Do you have 3cx tunnel enabled for remote connections?
    You can find this option under the provisioning tab in the extensions settings, select 3cx client from the phone list and scroll down to find the setting.
     
  20. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    I was NOT succesful.

    1. I select 3CX Client (Interface xxx.3cx.eu, SIP-Transport UDP, RTP Mode: Normal)
    2. I use 3CX Tunnel
    3. Config of 3CX Softphone:
    - Account Name: Softphone
    - Caller ID: Extension No.
    - Extension: Extension No.
    -ID: Extension No.
    - Password: Password from 3CX
    - In Office: xxx.3cx.eu
    - Out Office: xxx.3cx.eu
    - Use Tunnel yes
    - Tunnel Port: 5090
    - Tunnel PW: Tunnel PW
    4. I tried to get a Provision Mail, but I did't handle with google Cloud yet. Are ther other possibilities to get teh config file?

    Regards Matthias
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.