Unable to locate package 3cxpbx

Discussion in '3CX Phone System - General' started by nupton, Oct 5, 2016.

Thread Status:
Not open for further replies.
  1. nupton

    Joined:
    Oct 5, 2007
    Messages:
    26
    Likes Received:
    0
    Not a Linux guru, but have had some success with the SBC running on Pi. Can anyone tell me why I might see this error when trying to get the new linux beta installed. It comes up right after I enter the apt-get install 3cxpbx command.
    thnx
     
  2. Azuroth

    Joined:
    Oct 22, 2015
    Messages:
    6
    Likes Received:
    0
    Nupton,

    If you are using the noob install that was instructed for the SBC than it's most likely is running Ubuntu. To which I have found out while testing that there are certain packages (also known as dependencies) that are not installed in Ubuntu that 3CX requires. I've tried manually installed the dependencies and they are either no longer maintained or obsolete according to Canonical. I've also tried installing / trying to find newer versions of the needed dependencies and it still fails.

    The only way I have gotten v15 to install is by using an actual Debian distro and not one that is based off of Debian. I've also discovered that sudo is missing from Debian 8.X (jessie). So if you go this route, make sure to log in as root first and do
    Code:
    apt-get install sudo
    . You will need access to the image to install sudo.

    I haven't tried using a rpi with the ARM designed Debian image, but I don't for see much of an issue with installation.

    I hope this clears it up for you.
     
  3. nupton

    Joined:
    Oct 5, 2007
    Messages:
    26
    Likes Received:
    0
    Thanks Azuroth, I was using the noob install. I'll keep at it and update when I can
     
  4. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,127
    Likes Received:
    152
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Azuroth

    Joined:
    Oct 22, 2015
    Messages:
    6
    Likes Received:
    0
    It looks like there was only a package made for the Debian amd 64 architecture. So you probably wont be able to install on a pi at all unless you build a custom noobs image with the arm architecture. But I see way more headache going down that road. I think they should work on just building the packages for the different architecture instead of a custom ISO, though that would also be the plan with build the custom ISO as well.
     
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,127
    Likes Received:
    152
    Microsoft need to release asp.net core to run on noobs before you can even try. For now Debian only.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.