Unable to login

Discussion in '3CX Phone System - General' started by hayesmd, Oct 15, 2007.

  1. hayesmd

    Joined:
    Oct 15, 2007
    Messages:
    4
    Likes Received:
    0
    When I go to login to 3CX's web console I receive:

    ____________________
    Can't connect to the database server - invalid password or login name

    SQLSTATE[08006] [7] FATAL: password authentication failed for user "username"
    #0 C:\Program Files\3CX PhoneSystem\Data\Http\functions\CallContext.php(37): PDO->__construct('pgsql:dbname=ph...', 'username', '**********')
    #1 C:\Program Files\3CX PhoneSystem\Data\Http\functions\CallContext.php(86): CallContext->getConnection()
    #2 C:\Program Files\3CX PhoneSystem\Data\Http\functions\fExtension.php(66): CallContext->safeExec('select DN.IDDN ...', Array, 'Cannot get Exte...')
    #3 C:\Program Files\3CX PhoneSystem\Data\Http\functions\fObject.php(90): fExtension->getData()
    #4 C:\Program Files\3CX PhoneSystem\Data\Http\index.php(7): fObject->getManager()
    #5 {main}
    __________________________


    Any assistance would be greatly appreciated.
     
  2. zensoftware

    zensoftware New Member

    Joined:
    Aug 23, 2007
    Messages:
    225
    Likes Received:
    0
    May be an obvious question but the 3CX database server is running isnt it?

    If not goto a command line and run

    net start "3CX PhoneSystem Database Server"

    Neil
     
  3. hayesmd

    Joined:
    Oct 15, 2007
    Messages:
    4
    Likes Received:
    0
    Yes it is started... See my other post for finally getting it to start.

    http://www.3cx.com/forums/categorie...database-server---have-run-services-msc-2324/

    Towards the end you'll se where I got it working. It seems that since the phonesystem user account isn't added to the 'Users' group upon install that the database doesn't actually get created correctly.

    Does anyone know how to manually install the database?

    Everytime I uninstall/reinstall I have the same issue with the phonesystem account not being in the 'Users' group and cannot access the service.
     

Share This Page