Unable To Make Calls With GrandStream 4108

Discussion in '3CX Phone System - General' started by nmirza, Feb 25, 2012.

Thread Status:
Not open for further replies.
  1. nmirza

    Joined:
    Feb 25, 2012
    Messages:
    8
    Likes Received:
    0
    I have just setup a new 3CX account along with GrandStream 4108. I am hosting 3CX on a private server running Windows Server 2003 SP2 Enterprise Edition. I followed everything according to the manual but still can't get incoming or outgoing calls. When I make calls, I get no ringing on the phone and after a while I get a error message saying "server internal error." I am not sure what I am doing wrong. Please recent activity log from 3CX and screen shot of status page from GrandStream. Any help in resolving this will be greatly appreciated.

     

    Attached Files:

  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    It looks like the IP of the Grandstream is 192.168.123.141 (according to your post)...why then, is 3CX trying to send the call to IP 173.13.196.209 ? Is the Grandstream not on the same network? I think you may need to review your trunk settings, paying particular attention to the IP, in 3CX.
     
  3. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,064
    Likes Received:
    58
    Look at the port status on 3CX. It should be showing that the ports (10000, 10001,etc.) are not registered. Until they (ports) are registered, the 3CX system does not really recognize the GXW as being connected and is therefore telling you this in the logs. Go back and check your settings and also look at Grandstream's website as there is a document on how to set-up in the knowledge base. There does seem to be an issue with one setting regarding the number of simultaneous calls on each port. My experience suggests that 1 is not correct. I am using 2, but I only have 2 lines.
     
  4. nmirza

    Joined:
    Feb 25, 2012
    Messages:
    8
    Likes Received:
    0
    All ports are showing status as "Registered (idle)"

    The static IP address provided by Comcast (internet company) for us is 173.13.196.209. The local IP address to access the router is 192.168.123.1 and each machine assigned an IP is as 192.168.123.XXX. Do I need to change the 173.13.196.209 to 192.168.123.1? If yes, how do I do it since I can't seem to find that settings page on 3CX?
     
  5. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,064
    Likes Received:
    58
    Leejor is correct. If you are using the GXW as a PSTN interface, then where does Comcast come into the picture? Do you have remote phones somewhere?
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Is 3CX located on a remote server, with all your sets AND the gateway located elsewhere?

    I asked earlier but you didn't answer the question.

    If that is the case, and the gateway is located at your office BUT 3CX is located on a remote server, just a guess, then you probably have some port conflicts, and/or forwarding issues on your office network.

    If the gateway and 3CX are located on your office network, then , in the 3CX trunk settings, for this device, you need to put in it's IP , not your public IP.

    You need to provide more information on your set-up, it is very difficult to read minds. :)
     
  7. Insonic

    Joined:
    Sep 23, 2011
    Messages:
    1
    Likes Received:
    0
    his 3cx seems to be located at the same network

    > (16:54:03.343 [CM503001]: Call(67): Incoming call from Ext.1002 to <sip:5774320@192.168.123.142>)

    So he needs to point the IP of the PSTN gateway to 192.168.123.141 and everything should work
     
  8. nmirza

    Joined:
    Feb 25, 2012
    Messages:
    8
    Likes Received:
    0
    It is all hosted locally.

    leejor was correct. I just had the wrong IP in the trunk settings. Made the correction right now and we have phone calls. :D Thanks for your help!! :D :D
     
Thread Status:
Not open for further replies.