Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Unable to receive calls on line 3 of Grandstream 4104

Discussion in '3CX Phone System - General' started by jonnyfx, Feb 27, 2012.

Thread Status:
Not open for further replies.
  1. jonnyfx

    Joined:
    Feb 27, 2012
    Messages:
    4
    Likes Received:
    0
    I have 3 pstn lines connected to a Grandstream 4104.
    I am unable to receive incoming calls on line 3 of the Grandstream.
    Lines 1 and 2 are working perfectly.
    Lines 1,2 and 3 set up as 10000, 10001 and 10002 so trying to dial in on 10002.
    Grandstream status page showing phone number 1,2 and 3 as registered and pstn lines 1,2 and 3 as connected and idle.
    3CX ver 10 Ports/Trunks Status showing all 3 lines as green registered and idle.

    I get this error in the Server Activity Log when calling:
    16:19:37.195 [CM102001]: Authentication failed for SipReq: INVITE 10001@192.168.69.1 tid=b7927ee18fb29da5 cseq=INVITE contact=10002@192.168.69.23:5064 / 24729 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    I have a single inbound rule for each line redirecting to the same extension.

    Can anyone offer any insight into this??

    Thank you in advance.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,077
    Likes Received:
    324
    Did you go over all of your settings, for that trunk both in 3CX and the Grandstream? Be sure that you haven't duplicated something incorrectly if you did a cut and paste when setting up the trunks originally.

    Some users have done that (cut and paste), with a password (or other settings) and not realized that a space was introduced unintentionally at the beginning or end of the "word".
     
  3. jonnyfx

    Joined:
    Feb 27, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks for the advice, appreciated.

    I ended up deleting the PSTN gateway and recreated in 3CX. I chose 4 ports this time instead of 3 this time. Updated the credentials on the channel tab in the Grandstream. All 4 port status is ok in 3CX and in the Grandstream.

    The first 2 ports work correctly as before but ports 3 and 4 report the same error as before.

    Looking at the error in the log if the call is dialing into 10002 or 10003 (ports 3 or 4) why would the invite be to 10001? Is this why I am having problems?
     
  4. jonnyfx

    Joined:
    Feb 27, 2012
    Messages:
    4
    Likes Received:
    0
    SOLVED.

    Thanks for your help leejor, appreciated,

    I found out that the wrong settings were in the User ID field of the Unconditional Call Forward.
    Should have been:
    ch1-4:10002;

    instead of:
    ch1-4:10001;

    Thanks again, great forum.
     
Thread Status:
Not open for further replies.