Unable to transfer the call

Discussion in '3CX Phone System - General' started by 5qg4, Jun 23, 2007.

  1. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Unable to transfer the call.

    PBX Version: 3CX Phone System Version3.0.2295.0

    PSTN call => 1001@WG3804A-SAO => DR(808) Answer => at PSTN key in 201 => 201 pick up the call => 201 try to transfer the call to 219 but failed.
    The error is "Credentials don't match, check that authorization-ID and password match the ones in extension settings"

    My connections as below:

    192.168.16.10 ----VPN------> 10.1.1.218 <-------- 210.209.102.113 -NAT-> 192.168.2.110 and 192.168.2.101
    WG3804A-SAO ---- VPN ----> 3CX PBX BOX <------------ NAT ------ 201 (Grandstream GXP2000) and 219 (eyeBeam soft phone)

    All the devices can register to 3CX PBX BOX, all of them are registered successfully.


    The server log shows server activity and detailed logging Messages as below:
    ----------------------------------------------------------------------------
    17:05:09.062 StratLink::eek:nHangUp [CM104001] Call(22): Ln:1001@WG3804A-SAO hung up call; cause: BYE; from IP:192.168.16.10
    17:04:58.187 AuthMgr::eek:nAuthFailure [CM101000] Registration request from sip:201@210.209.102.113:43654 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    17:04:58.187 AuthMgr::requestCredential [CM001005] Message SipReq: REFER 1001@10.1.1.218:5060 tid=5343ebedf7aea843 cseq=REFER contact=201@210.209.102.113:43654 / 13953 from(wire) failed authentication!
    17:04:41.640 AuthMgr::eek:nAuthFailure [CM101000] Registration request from sip:201@210.209.102.113:43654 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    17:04:41.640 AuthMgr::requestCredential [CM001005] Message SipReq: REFER 1001@10.1.1.218:5060 tid=48e90a960baeb749 cseq=REFER contact=201@210.209.102.113:43654 / 13950 from(wire) failed authentication!
    17:04:20.875 CallLegImpl::eek:nConnected [CM103001] Call(22): Created audio channel for Ext.201 (210.209.102.113:43598) with Media Server (10.1.1.218:7074)
    17:04:20.875 StratInOut::eek:nConnected [CM104005] Call(22): Setup completed for call from Ln:1001@WG3804A-SAO to Ext.201
    17:04:18.593 CallConf::eek:nProvisional [CM103003] Call(22): Ext.201 is ringing
    17:04:15.812 MediaServerReporting::DTMFhandler [MS211000] Call(22) Ln:1001@WG3804A-SAO: DTMF (in-band) from 192.168.16.10:16384 detected.
    17:04:15.406 MediaServerReporting::DTMFhandler [MS211000] Call(22) Ln:1001@WG3804A-SAO: DTMF (in-band) from 192.168.16.10:16384 detected.
    17:04:14.984 MediaServerReporting::DTMFhandler [MS211000] Call(22) Ln:1001@WG3804A-SAO: DTMF (in-band) from 192.168.16.10:16384 detected.
    17:04:10.781 CallLegImpl::eek:nConnected [CM103001] Call(22): Created audio channel for Ln:1001@WG3804A-SAO (192.168.16.10:16384) with Media Server (10.1.1.218:7072)
    17:04:10.750 CallConf::eek:nIncoming [CM103002] Call(22): Incoming call from 1001 (Ln:1001@WG3804A-SAO) to sip:801@10.1.1.218
     
  2. Anonymous

    Anonymous Guest

    I believe you had some previous issues with your DB?

    Would you be able to delete and recreate the extensions you use?

    The authenticaton error relates to invalid pwd, username or both (but you know that) so perhaps something got unstuck in the db.

    Also there might be an issue on the firewall.
     
  3. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    I think the DB should be OK. Since I have try to delete and recreate also get the same result.

    All the extensions under NAT can issue calls or answer the incoming calls are no problem. Conference aslo OK excepted call transfer.

    Today, I also hit the voice delay 7 sec. At system log, there is no abnormal log had been found. Then I drop the call, and issue the call again. This time back to normal.
     

Share This Page