Upgrade NGINX in Linux v15

Discussion in '3CX Phone System - General' started by Robert Juric, Jul 11, 2017.

Thread Status:
Not open for further replies.
  1. Robert Juric

    Joined:
    Jan 14, 2017
    Messages:
    11
    Likes Received:
    0
    I have a client who needs to upgrade nginx for PCI compliance. The version included with the linux distro is 1.6.1 and they need to be running at least 1.8.1, while current version is 1.12.1.

    Is there any straightforward way to upgrade NGINX without breaking all of 3CX?
     
  2. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    You are asking the wrong question but the answer is no. 3CX doesn't control the distribution and per this https://packages.debian.org/jessie/nginx the current version of nginx distributed with Debian Jessie is 1.6.2. So you can certainly ugrade to that yourself (apt-get update; apt-get upgrade) but beyond that this is a Debian question not a 3CX question.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    Just a follow-up. It looks like nginx is updated to 1.10.3 in Debian Stretch. There is also this article about putting 3CX on Debian Stretch but the recommendation is to wait until it is officially supported. So hopefully in a few weeks time you'll have a support 3CX install that is PCI compliant.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Robert Juric

    Joined:
    Jan 14, 2017
    Messages:
    11
    Likes Received:
    0
    We installed 3CX from the provided Linux ISO. Since the included version included with Debian Jessie is only 1.6.2, it won't upgrade via apt-get (it says it is running the latest). To upgrade nginx I would have to add the nginx apt source directly, or manually install.

    I wasn't asking about the possibility of upgrading the package. As you said, that is a Debian question. My question was whether or not that would have any repercussions within 3CX. In this I was refererring to other dependencies or web interface source/config files.

    We were hoping others may have ran into this in the past, surely we are not the first the attempt to run 3CX in a PCI compliant environment.
     
  5. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    You just may be the first to run 3CX in a PCI compliant environment. I'm assuming others segment it off from any network that needs to be compliant. But again, I would venture Debian Stretch will be be supported soon which should resolve the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.