Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Upgrading 3cx 12.0 to 15

Discussion in '3CX Phone System - General' started by Joe Schmitz, Feb 8, 2017.

Thread Status:
Not open for further replies.
  1. Joe Schmitz

    Joined:
    Feb 8, 2017
    Messages:
    21
    Likes Received:
    1
    1.) If upgrading from 12.0, do I have to go to 14 first, or do I have to upgrade to 12.5, then 14, then 15

    2.) I have 4 3cx servers all interconnected. If all of them are on 12.0, do I have to upgrade each one incrementally (12.0 to 12.5 to 14 to 15) or can I update one server just to 15 before starting another?

    3.) I have licenses for 12.0. Does that license carry over to the newer versions of 3cx?

    Edit: I may have misspoke, I have 12.5 installed on all of the VOIP servers.
     
    #1 Joe Schmitz, Feb 8, 2017
    Last edited: Feb 8, 2017
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
  3. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    458
    Likes Received:
    75
    Leejor is correct. The bridge should work but some of the advanced features (presense, etc) will not work with dissimilar versions. Also I believe this isn't officially supported to bridge between different versions and since it is bridging with a system two major versions old it will be worse. As to the license question as long as the licenses have "maintenance" that isn't expired they will go from v12.5 to v15 with no issues. Make sure the 12.5's have the latest service pack installed before running their backup and uninstall.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,613
    Likes Received:
    243
    Here is the actual documentation on this:

    https://www.3cx.com/docs/manual/configuration-tool/

    At the bottom you will see this:

    • From v9 and v10 you must upgrade to v11 SP 4a first, then to v12 SP 6.1
    • From v12 SP 6.1 you must go to v12.5 first.
    • From v12.5, to retain call logs, you must go to v14 first, or without call logs directly to v15.
    • From v14 you can go to v15 directly.
    • Backups from previous versions can only be restored during the installation of the pbx.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,400
    Likes Received:
    535
    Regarding licensing you need to have active maintenance to be able to upgrade from one version to the next. Once you do license keys will upgrade automatically as you go up the versions.
     
  6. Joe Schmitz

    Joined:
    Feb 8, 2017
    Messages:
    21
    Likes Received:
    1
    Thank you very much everyone for answering my question! :) Very helpful.
     
Thread Status:
Not open for further replies.