Username with non-alphanumeric signs

Discussion in '3CX Phone System - General' started by Remuz, May 11, 2007.

  1. Remuz

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    My proxy provider is digisip. In Asterisk I use the following line to register:
    Code:
    register => 08xxxxxxxx:password:16xxx@proxy.digisip.net/1000
    So I want to set something similar up in 3CX but as I add : to the userid it gives away the ASCII code 3A instead. My log says like this:
    Code:
    Registration of 08xxxxxxxx%3Apassword%3A16xxx@proxy.digisip.net has failed; reason=Unauthorized.
    Any suggestions? Is it the DB that doesnt handle the signs?
     
  2. silentfun

    silentfun Member

    Joined:
    Dec 11, 2006
    Messages:
    364
    Likes Received:
    0
    not sure but i thing the ":" have brogen the semantic rules of the program

    as a fast workaround try to change your login at your provider if you can do. if not knee down and pray. :))

    Hank what do you thing about this?
     
  3. Remuz

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    I cant change the login :(

    There must be a way to not use the DB to store the login but a pointer to maybe a file with the logon-info. I dont really know how the system is built so I just drop suggestions :p

    I guess the DB-data is expanded to avoid unwanted signs and that the compress function isnt translating 3A to : Am I right?
     
  4. Remuz

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    The thing is the digest username. As I have to set the phone logonid to the phonenumber in the program to get the request as 08xxxxxx@proxy.digisip.net. If I just set caller ID to the number and use logonid it will request like 16xxx@proxy.digisip.net (in this case the digest username is allright, but the server will refuse since I register 16xxx@proxy.digisip.net)
     
  5. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Please, try the following:

    1. Open line settings page for your line
    2. In the section Authorization
    - set ID to be 08xxxxxxxx
    - set Password to be 16xxx
    3. Voila!
     
  6. Remuz

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    That gives me following:
    Code:
    To: "08xxxxxxxx"<sip:08xxxxxx@proxy.digisip.net>
    Code:
    Authorization: Digest username="08xxxxxx",realm="proxy.digisip.net",
    nonce="464493408acd41e2ad9a6ae8668740d3801ea776",
    uri="sip:proxy.digisip.net",
    response="bbda7bd08be224b5f6b528fb76d7d1e4",
    algorithm=MD5
    What I need is:
    Code:
    To: <sip:08xxxxxxx@proxy.digisip.net>
    Code:
    Authorization: Digest username="16xxx", realm="proxy.digisip.net", algorithm=MD5, uri="sip:proxy.digisip.net", nonce="4644558cdae6d93409fdda62ec282458f1ec4991", response="90498b0e94e0578387d5d7694bfa3fda", opaque=""
    Wich I cant get since 3CX uses:
    Code:
    To: "OutboundCID"<sip:LoginID@proxy.digisip.net>
    Code:
    Authorization: Digest username="LoginID",realm="proxy.digisip.net",
    nonce="46445b3a564616fc637fa4579cd8b41040a2b64b",
    uri="sip:proxy.digisip.net",
    response="9cdf6856f029496ec24f4a1f550250bc",algorithm=MD5
    Where LoginID is the ID under Auth and OutboundCID is the Outbound caller ID. The LoginID in the first <SIP> should be (at least in my case, maybe they dont follow RFC) OutboundCID
     
  7. Remuz

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    http://www.3cx.com/forums/viewtopic.php?t=986&start=0&postdays=0&postorder=asc&highlight=register

    Seems it has been up here before :/

     

Share This Page