Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Using 3CX Externally

Discussion in '3CX Phone System - General' started by gateway978, Feb 15, 2012.

Thread Status:
Not open for further replies.
  1. gateway978

    Joined:
    Jan 21, 2012
    Messages:
    6
    Likes Received:
    0
    Hi,

    I'm probably being an idiot, but I'm completely lost when it comes to setting up my server to use externally.
    We have a static IP address on the router, and the machine is obviously static'd to the internal network, but does the machine need an external/public IP itself, that is separate from the static IP of our network? (if this is even possible!)

    Because, at the moment my setup is:

    Public IP: Public IP of the router/network
    STUN Server: Everything is set to the default (Although, I have tried turning it off and setting the public IP to the same as the Public IP)
    Ports: All are mapped in the Firewall (We use a NETGEAR ProSafe)

    In Advanced:
    The custom parameter that has to be enabled is definitely enabled.

    The extension is 'allowed' to be connected to externally, and through the tunnel as well.

    I have tried connecting to the server through my Android App (Over wifi and T-Mobile), and at home using a Softphone over BT Home Broadband.

    Can anyone point me in the right direction please?

    Thanks and sorry!

    Ryan
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,079
    Likes Received:
    324
    The machine running 3Cx doesn't require a public IP, just a private one from your router. There are users that have problems with some VoIP providers if STUN is left enabled, I would leave it enabled unless/until it causes problems, and disabling it fixes the problems.

    You should (if you haven't already done so), run the 3Cx firewall checker. have a look at the results, if anything is amiss then there is probably something not set properly in your router (port forwarding/options), or, a firewall conflict/issue in the machine running 3CX.

    Go into the 3CX logs right after an attempted registration by a remote extension, is there any sign of it?

    If not, then something is blocking it (Firewall checker results?), or the remote set is not "pointed" to the right place. Since you are having problems with more than one set, from more than one location, I may be wrong, but, I'll assume the former.

    Here is some reading for you.. http://www.3cx.com/blog/voip-howto/troubleshooting-direct-remote-extension/
     
Thread Status:
Not open for further replies.