Using Polycom Templates from older versions of 3CX with V11

Discussion in '3CX Phone System - General' started by pjr, Dec 18, 2012.

Thread Status:
Not open for further replies.
  1. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    Hi,

    We have a number of clients running legacy versions (ie V8) of 3CX who we wish to upgrade to V11. We spent a huge amount of time learning about the Polycom template files and have made lots and lots of customisations to get things working in the way the clients wanted with their phones.

    The move to V11 means the default Polycom templates for the phones we use (IP550, IP321, IP331) are based on the 4.0 Polycom firmware which uses an entirely new style of template file. I am trying to avoid have to relearn everything we have already done and reduce any disruption to our clients.

    In addition we also have a large install base of IP330 phones that dont support the 4.0 firmware.

    Ideally I would like to be able to bring over the templates from my V8 installs into the V11 server and use these? Is this possible?

    I know it would be "unsupported" and I am willing to accept that.

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    Re: Using Polycom Templates from older versions of 3CX with

    Well I just copied over the templates from the old V8 system to the same location on V11, restarted the services and the templates are there and I have migrated a phone.

    All looks OK for now.

    I imagine there is still a risk that a feature in 3CX relies on something implemented in V4.0 of the polycom firmware, but I feel this is unlikely to be an issue for the functionality my clients use.

    Has anyone else done anything similar to me and had issues?

    Thanks

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    Re: Using Polycom Templates from older versions of 3CX with

    Hi Paul,

    I don't have the same investment in custom templates for Polycom as you. I started down that road but have since abandoned it for 3cx standard templates. I use v11 and polycom in two sites. (I wish they were not Polycom, but they were my first 2 sites).

    One site has 330's and 550's, and it's not too bad because the phones are all from the same generation. Another uses some 330's, but mostly 601's - which have been discontinued for some time.

    Aside from having to have different (and differently named) .ld files in the provisioning directory for different generations of phones, I have had good success with recent 3cx provisioning files for Polycom - allowing to select even the old hardware versions from within the standard templates.

    I'm now using these templates, rather than custom or modified templates - it's easier than figuring out what happened to the custom templates after upgrades, and worrying about whether they'll still work after restoring them.

    We don't get anything fancy out of the polycoms by doing this, but at least they work, and I don't have to fight after 3cx version updates. I'll be happy when they are all retired in favor of anything else that's easier. Newer sites have Grandstreams which are a piece of cake, and a supplier tells me I should try yealink.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    Re: Using Polycom Templates from older versions of 3CX with

    Hi Les,

    Thanks so much for taking the time to reply.

    I have a few questions and was hoping you can answer them if that's ok?

    On the site that has 330's and 550's what firmware are you running for the Polycoms? I understand the 330's cannot support 4.0 onward but the 550's can. 3CX V11 has a 4.0 template for 550's but a 3.3.3 based template for 330's.

    How have you managed to run this, as I am under the impression I can only have one firmware in the provisioning folder, and if I use the 4.0 firmware, the 330's will just try and download it and get in a reboot loop as they dont support it? Is this not the case? Is there are way to have 2 different versions of firmware in the provisioning folder so both can coexist?


    When you say you have selected old hardware versions from within the standard templates, how have you done this and what does this allow?

    Thanks

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    Re: Using Polycom Templates from older versions of 3CX with

    I think if you look in the polycom templates that are provided, you'll see how the different models will use different firmware files. You need to download them all from Polycom, and rename the appropriate fw files to match what's listed in the templates.

    I believe it was by looking at the provisioning templates that I discovered the instructions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.