V1.0.20-4G doesnt start after first time use (Fixed 1.0.24))

Discussion in 'iOS' started by xav78, Dec 28, 2010.

Thread Status:
Not open for further replies.
  1. xav78

    Joined:
    Sep 10, 2010
    Messages:
    9
    Likes Received:
    0
    Hello,

    I had for christmas the iphone 4 to replace the 3 I had.
    It looks like the 3CX is not working correctly so as probably already mentionned.
    First start, all is OK and then you have access to all. Registring is good. When exit and try to again enter, system will just appear black, and will remain in background, no registration and ability to use it. After a while, it will even return to the icons or you will see a red line saying "phone" on the top but still not able to use anything.
    The workaround is to close the background application ( 2 home touch, then suppress the application ) go into the setup, go to 3CX, and then remove the user name.
    Restart the 3CX and you should be able to access to it with the registry choice.

    Hope this help
     
  2. No-body

    Joined:
    Aug 19, 2010
    Messages:
    13
    Likes Received:
    0
    Re: Iphone4 4.2.1 and 3CX

    I do have the exact same problem, also new Iphone4 with 4.2.1 installed and new download from itunes.(v1.0.18)

    *edit:
    did a reinstall with v1.0.19 but its still the same problem. First time boot you can enter the profile and everything is working. But on next registration the app freezes with black screen and crashes back to Desktop from now on for every registration you have to use the workaround from the first post.
     
  3. No-body

    Joined:
    Aug 19, 2010
    Messages:
    13
    Likes Received:
    0
    Re: Iphone4 4.2.1 and 3CX

    Uninstalled v1.0.19, rebooted phone, installed fresh new version (1.0.20) from ITunes. Still the same problem. First time setup and registration works, after that app keeps crashing on startup. Workaround from OP still works.

    Just read some posting guidelines, unfortunately i cannot change the topic title.
    Device:
    iPhone 4
    Os 4.2.1
    Jailbreak: No
    Cydia: No

    Handset: Phone
    Contacts: Exchange
    Server: Intern
    Network: Wifi

    3cx Software version 1.0.20 (also tried 1.0.18 & 1.0.19)
     
  4. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: Iphone4 4.2.1 and 3CX

    Hello Guys,

    we have in the forum 3 reported issues like this.
    Unfo. we have also an 3GS and 4G here and we where not able to replicated this in our tests.
    There is version 1.0.21 on the way with some fixes for the profiles but I think this will not help you guys.

    Can you plz make an screenshot of your setting, ensure that you dont have spaces before or after the entered vaules.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. slm72

    Joined:
    Sep 21, 2009
    Messages:
    11
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Investigat

    I'm having same issue, when I launch the app, the screen just goes black for about a 30 seconds then the app crashes and returns to the home screen. Have had this issue for about 2 months have been waiting for updates the latest update has not fixed this issue...

    Device Info
    -------------------------------------------------------
    Phone Model: iPhone
    Generation: 4
    Firmware Version: 4.2.1
    Jailbreak: No
    Cydia Installed: No

    Issue Info
    -------------------------------------------------------
    Handset: Phone
    Contacts: Exchange
    Connection: WiFi
    Server: Internal
     

    Attached Files:

  6. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: V1.0.20-4G doesnt start after first time use (Investigat

    Dear SLM72,
    check out the next build 1.0.22.
    Can you make me plz a big fav.
    Remove the app, restart the phone.
    Reinstall the app and then take an screenshot of the settings you placed in the phone.
    If it has confidential settings send it plz to sw@3cx.com
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. slm72

    Joined:
    Sep 21, 2009
    Messages:
    11
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Investigat

    Stephan,

    I uninstalled the app, restarted phone, reinstalled the app and the app did launch and let me make a call. Upon closing the app, I was no longer able to open it again, same symptoms. I've emailed you the screen shots from my settings pages on my phone as requested. Thanks for you assistance.
     
  8. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: V1.0.20-4G doesnt start after first time use (Investigat

    Steve,

    plz open this Folder:

    C:\Users\sw\AppData\Roaming\Apple Computer\Logs\CrashReporter\MobileDevice

    You have to change the user name fitting urs.
    When you are there, open the Name of your Device.
    Clean all files in this folder.
    Remove the app
    reinstall the app
    register it to the pbx
    exit as you would normally do
    restart the app with the crash

    Then ZIP me plz all files in this folder after you have attached you iphone with itunes (this syncs the crash reports to this folder)

    One thing we can check as well.
    Can you install when the phone is now in this "bad" state
    http://itunes.apple.com/us/app/system-activity-monitor/id306192663?mt=8
    Tell me under Processes if you can see still, even when you exit the app, our 3CX Phone?
    Then the phone may stuck on ur device when it should be terminated already.

    Thx for helping us on this!
    Send me an e-mail as before.
    Thx
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. No-body

    Joined:
    Aug 19, 2010
    Messages:
    13
    Likes Received:
    0
    Re: V1.0.22-4G doesnt start after first time use (Abandoned)

    Found some time to create new logs with version 1.0.22.
    Hope you can find something to solve the problem.

    Clean all files in this folder. - DONE
    Remove the app - DONE
    reinstall the app - DONE
    register it to the pbx - DONE
    exit as you would normally do - DONE
    restart the app with the crash - DONE

    App seems to crash after registration was lost and trying to reregister.
     
  10. panos.ch

    Joined:
    Mar 4, 2010
    Messages:
    6
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Abandoned)

    Hi there,
    I have same issue. Did you found any solution about this?

    Panos
     
  11. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: V1.0.20-4G doesnt start after first time use (Abandoned)

    the solution will maybe in 1.0.23.
    The app does not start in time and will be term. by the iOS it self.
    We improved the startup and hope for you all that this issue will be gone after.
    Hopefully by end of the week you can update to this version.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. No-body

    Joined:
    Aug 19, 2010
    Messages:
    13
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Abandoned)

    Deinstalled 1.0.22
    Installed 1.0.23

    Still the same problem,
    Started app, created profile, first time reg takes a long time (ca 45sec), but registers. Calling works.
    Exit app.
    start app again --> black screen --> crash to springboard

    Workaround still the same, makesure app is not running on background, delete registering settings, start app and choose profile or create new profile -->app registers again like first time.
     
  13. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: V1.0.20-4G doesnt start after first time use (Abandoned)

    Hello, Info for Upcoming version, this will be fixed in 1.0.24 coming soon to the App Store
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. tymes

    Joined:
    May 11, 2011
    Messages:
    1
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    have original iPhone with 1.0.23 and same problem.

    my workaround is to go to settings & break config so in 3cx use bad stun server (add x) or switch from external to blank internal... ultimately apps starts unregistered and I fix the setting in app and it works... then when closing app I may add x to stun or again break settings so I can get back in next time skipping going to settings unless I forget or was interrupted.

    so when is 1.0.24 gonna be avail? it is a major problem that the app doesn't start normally and most people must uninstall reinstall to get it to work....
     
  15. antler

    Joined:
    May 8, 2011
    Messages:
    40
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    Hallo 3cx,

    Any news on when v 1.0.24 will be available for general release?

    Thanks in advance,

    Antler
     
  16. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    in the next 2 to 3 weeks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. antler

    Joined:
    May 8, 2011
    Messages:
    40
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    Hallo Stefan,

    Still anxiously awaiting this new version, any update to the 2 -3 weeks posted on 27th June 2011 for us please.

    Also, I see in another post with the title '3cx tunnelling' an answer by 'complex1' mentioning another version 1.0.25, will this supercede the .24? but again, same question, when are the updates due?

    Many thanks and keep up the good work,

    Antler
     
  18. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    84
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    guess why it takes so long....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. MyJuliet

    Joined:
    Aug 10, 2011
    Messages:
    2
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    My application uninstall, restart the phone, reinstall the application and the application does not start, and let me make a call. Close the application, I could not open it again, same symptoms. I emailed you screen shots from my cell phone is set to R Page
     
  20. ackrts

    Joined:
    Feb 5, 2008
    Messages:
    7
    Likes Received:
    0
    Re: V1.0.20-4G doesnt start after first time use (Fixed 1.0.

    Hi,
    We're having the same issue with a brand new iphone 4 (white). It seemed to work for a few weeks, then all the sudden upon application launch the black screen for about 20 seconds then the app goes away. I've reinstalled twice. After installation and initial configuration the phone registers (seems to take a long time to register). I can make calls just fine. Once I exit the application and go back in, I just get the same black screen. We have another iPhone 4 (black) running with no issues. Both using 1.0.23 and running iOS 4.3.3.
     
Thread Status:
Not open for further replies.