V12.5.32- RING on Push?

Discussion in 'Android' started by patrickrivard, Jun 23, 2015.

Thread Status:
Not open for further replies.
  1. patrickrivard

    patrickrivard New Member

    Joined:
    May 29, 2008
    Messages:
    100
    Likes Received:
    0
    Device Info (BTW, same exact problem with IOS phones)
    -------------------------------------------------------
    Phone Model: [Nexus 5]
    Firmware Version: [5.1.1]

    Issue Info
    -------------------------------------------------------
    Handset: [Phone does not ring/vibrate when it receives Push Notifications]

    Can anyone tell me if they were able to get the phone to Ring/Vibrate like its suppose to when you get a call via the "Push" notification?
    If so, I would greatly appreciate if you can share your experience/knowledge on that topic.

    Thank you
     
  2. Futureweb

    Futureweb New Member

    Joined:
    Jun 29, 2015
    Messages:
    163
    Likes Received:
    14
    Hello,
    I got the same Problem with my Setup ...
    Phone receives Push Notification (shows lost call) - but Phone does not ring/vibrate when the Push Notification is received ... so not really useable! :-/

    3CX v12.5.42341.999
    Phone: Huawei Y330-U01

    Any Feedback on this?!

    thx, bye from Austria
    Andreas Schnederle-Wagner
     
  3. Leonidas 3CX

    3CX Support

    Joined:
    May 6, 2015
    Messages:
    12
    Likes Received:
    0
    Hello,

    Could you please verify whether you have performed the latest service pack updates?
    Also please make sure that the phone is not in mute mode
     
  4. patrickrivard

    patrickrivard New Member

    Joined:
    May 29, 2008
    Messages:
    100
    Likes Received:
    0
    We have the latest "service Pack"!!!
    And NO, the phone(s) (all brand and models) are not on "Mute".... What type of comment is that?????

    I'm really wondering why I even bother to post my questions on this forum when I get answers like this....

    Thank you for all and any help, but this is not helping...

    Patrick Rivard
     
  5. AlexHeylin

    Joined:
    Nov 30, 2015
    Messages:
    44
    Likes Received:
    9
    Probably not what you want to hear but on v14 this is MUCH better. It all basically just works properly for us. YMMV
     
  6. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Yes, update to V14 now push plays ringtone and btw it can be customizable.
    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. patrickrivard

    patrickrivard New Member

    Joined:
    May 29, 2008
    Messages:
    100
    Likes Received:
    0
    Thank you for your comments.
    Yes V14 has resolved this issue, it now works fine with the "Push" notifications.
    This part is solved...
    Now the only part left to solve would be to get the Choppy Audio issue resolves on some devices running Android 6.0 (6.0.1).
    Keep up the good work.

    Thank you
     
  8. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,338
    Likes Received:
    76
    I can't see anyone having asked this but is the 3CX Phone app set to use the 3CX Tunnel? Could you make sure in the Extension Settings in the Management Console that you have the Tunnel enabled for that extension and that it is also enabled on the Android App?
     
  9. patrickrivard

    patrickrivard New Member

    Joined:
    May 29, 2008
    Messages:
    100
    Likes Received:
    0
    @ NickD_3CX
    Are you talking about the "Ring on Push" issue or the "Choppy Audio" issue???
     
  10. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,338
    Likes Received:
    76
    You're right, I didn't clarify that. I was referring to the Choppy Audio issue. One more thing I couldn't find mentioned was if you get Choppy Audio even when connecting over WiFi but on the same LAN as the 3CX Phone System.
     
  11. Futureweb

    Futureweb New Member

    Joined:
    Jun 29, 2015
    Messages:
    163
    Likes Received:
    14
    Hi NickD,
    we got similiar Problems with choppy Audio on Android 6 (Nexus 5X & Nexus 5) - no matter if we are within the same Network (WLAN) or on Mobile Network ...
    With Android 5 Phones / IPhones we got no Problems at all ...
    Using 3CX V14SP2.

    Tested:
    Android 6 User and Android 5 User standing next to each other - booth within Company WLAN - Signal Strength 100% ... both calling a Queue with Voice+Music ... Android 5 = perfect Sound Quality, Android 6 = choppy Audio ... tested with Nexus 5 and Nexus 5X - both on Android 6.

    Andreas Schnederle-Wagner
     
  12. patrickrivard

    patrickrivard New Member

    Joined:
    May 29, 2008
    Messages:
    100
    Likes Received:
    0
    @ NickD_3CX
    To answer your questions, there no better way than to look at the following thread...
    http://www.3cx.com/forums/viewtopic.php?f=34&t=41825&view=unread&sid=0ac70f53750b2b4c5c9ba950ba0ea34b#unread

    Thank you for any help in solving this issue. But it appears that others (MichaelB and agp) have "kind-of" admited the problem and are, apparenly, working on solving this issue affecting thousands of Android users...

    But who really cares about Android users anyway, we're only just about 85% of your potential customer base...
     

    Attached Files:

  13. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,338
    Likes Received:
    76
    So I got an update on the audio issue problems, indeed there seems to be something on Android OS after 5.1 (Lollipop) that is causing the SIP engine to play up on newer versions.
    I was told that it is currently being investigated to see what is causing this and how to get it fixed.

    I'll try to keep this thread updated with the progress on this matter.

    EDIT: The issue seems to affect also Android 5.1, versions up to 5.0.1 should be OK.
     
  14. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,338
    Likes Received:
    76
    Just an update on this issue, I just got word today from the R&D department that the cause of the issue has been identified and a fix has been implemented and it is currently being tested internally.
    We are not quite yet ready to release it officially as we are currently revising all the functionality of the 3CX Phone app to make sure nothing else has been affected by the changes.

    I will provide another update when I have news about this.
     
Thread Status:
Not open for further replies.