V14 force MakeCall rather than CTI mode

Discussion in '3CX Phone System - General' started by nickjhunt, Nov 2, 2015.

Thread Status:
Not open for further replies.
  1. nickjhunt

    Joined:
    Apr 25, 2013
    Messages:
    42
    Likes Received:
    0
    I am running V14Sp1 and need to be able to accept multiple calls on my extension. The 3CX softphone however has a habit of auto answering some of these calls. I am aware that there is an issue with the way that CTI runs that precludes accepting multiple calls but I cannot seen to be able to disable CTI. I have the 'Use intercom for make call' de-selected but it still does it.
    Phone is a grandstreamGXP2124 which I am aware is no longer supported but it was when we purchased loads of them when we introduced 3CX
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,416
    Likes Received:
    277
    My Grand-stream 2130's use MakeCall and also do not have issues with CTI as far as I know.

    Although this is for Yealink, perhaps the same option applies:
    http://forum.yealink.com/forum/archive/index.php?thread-2430-3.html

    There is an XML file that needs a mod on the server.
    C:\ProgramData\3CX\Data\Http\Interface\MyPhone\cti_template.xml
    You remove the URL for Answer_Call
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nickjhunt

    Joined:
    Apr 25, 2013
    Messages:
    42
    Likes Received:
    0
    Thank you, just what I was looking for.
     
  4. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    445
    Likes Received:
    73
    Thanks for this. Do the services need to restart after applying the change?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,416
    Likes Received:
    277
    i understood IISRESET only, then exit 3cxPhone and reopen.
    (Remember to terminate it completely and not just "X" as that minimizes it to the Notification area only.)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.