Solved v15 Email Settings fail

Discussion in '3CX Phone System - General' started by tyfrantz@gmail.com, Dec 16, 2016.

Thread Status:
Not open for further replies.
  1. tyfrantz@gmail.com

    Joined:
    Sep 21, 2015
    Messages:
    5
    Likes Received:
    0
    Migrated from v14 (Windows) to v15 (Debian) and the whole thing was done in 30 minutes with all phones/trunks reconnecting right away - it was quite brilliant.

    However, one area of settings did not successfully come over and that is the email settings. In v14 it was working just fine, v15 it had some stock 3cx server settings. I've applied correct settings and hitting the test button wasn't doing anything at first. Multiple tried, waiting for a couple of minutes before reloading the page. I've applied settings with "OK", completely logged out and logged back in with a different browser to make sure the settings were legitimately applied. I now get this message which shows up when I click test:
    • MailKit.Net.Smtp.SmtpCommandException: <pbx@gahangel.com> previously hard-bounced at MailKit.Net.Smtp.SmtpClient.OnRecipientNotAccepted(MimeMessage message, MailboxAddress mailbox, SmtpResponse response) at MailKit.Net.Smtp.SmtpClient.ProcessRcptToResponse(MimeMessage message, MailboxAddress mailbox, SmtpResponse response) at MailKit.Net.Smtp.SmtpClient.FlushCommandQueue(MimeMessage message, MailboxAddress sender, IList`1 recipients, CancellationToken cancellationToken) at MailKit.Net.Smtp.SmtpClient.Send(FormatOptions options, MimeMessage message, MailboxAddress sender, IList`1 recipients, CancellationToken cancellationToken, ITransferProgress progress) at MailKit.Net.Smtp.SmtpClient.Send(FormatOptions options, MimeMessage message, CancellationToken cancellationToken, ITransferProgress progress) at MailKit.MailTransport.Send(MimeMessage message, CancellationToken cancellationToken, ITransferProgress progress) at GenericUtilsNet.Mail.Send(AlternateView calendarData) Response:
    I am not sure what much of this means. I was certain of the credentials, but I tested them to be safe and they are correct.

    Help!

    UPDATE: Nevermind, it spontaneously started working despite the weird error message "Test" throws. And i can't figure how out to delete this thread, so LOOK NO MORE.
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Hello there,
    Thank you for the update and glad to hear the issue is resolved. Leave the post as is, maybe someone else gets the same error and finds this post useful and wants to continue the conversation.
     
  3. salomaowk

    Joined:
    Jan 23, 2017
    Messages:
    3
    Likes Received:
    0
    Hi, I had a very successful Google Cloud/Debian 8 instance installation but the email is not working.
    I am sure about the credentials because I've tested them using my Gmail account, but it's still not working inside 3CX.

    When I click the button "test", nothing happens but the email is not coming.

    Is there Any extra step to verify or proceed into Google Cloud DEBIAN/3CX installation to make email process work out?

    Please advise.

    Thank you!
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,947
    Likes Received:
    178
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. salomaowk

    Joined:
    Jan 23, 2017
    Messages:
    3
    Likes Received:
    0
  6. Lim LT

    Joined:
    Feb 9, 2017
    Messages:
    2
    Likes Received:
    0
    thanks all for sharing, having the same problem, i just tried it and it worked but just wondering will the email account credential exposure being compromise??
     
  7. ccomley

    Joined:
    Apr 6, 2011
    Messages:
    92
    Likes Received:
    4
    My solution to the google cloud issue was very simple.

    I have my office firewall set up to collect on port 26 and forward that traffic to my in house mail server on port *25*.

    Now all I have to do is set 3cX hosted instances up to use port 26 instead of port 25 for outgoing email and to send via my office server! Works a treat.

    Before I found you could change the email port in the 3CX settings pages, I had also worked out how to do this with an IPchains setting on the host VM.

    The place to change it in 3CX is Settings/Parameters and look for "MLSRVPORT" - you'll find it's set to 25.

    How to make the change on your firewall I can't say - I know how to do it on a Sonicwall! :)
     
Thread Status:
Not open for further replies.