V15 gets corrupted after accessing 3cx Management Console

Discussion in '3CX Phone System - General' started by sfchampeau, Oct 30, 2016.

Thread Status:
Not open for further replies.
  1. sfchampeau

    Joined:
    Oct 30, 2016
    Messages:
    8
    Likes Received:
    0
    This scenario has happened twice in a week to me when I try and access the "Welcome to the 3cx Management Console".

    In the dialog box it indicates to enter user name or extension number / password. So, experimenting I enter my extension and passcode from my user account. Failed to login "that ok", but now I'm unable to access via my admin login I reboot 3cx and webpage shows Bad Gateway 502 I try and login, but get a server error.

    I have 3cxV15 installed as a guest operating to vmwork station 12.1 with 1gb memory and 20gb space.

    Thanks,
     
  2. agp

    agp 3CX Team

    Joined:
    Aug 19, 2015
    Messages:
    140
    Likes Received:
    21
    Hi sfchampeau,

    Just to test, can you try logging in from another computer?
     
  3. sfchampeau

    Joined:
    Oct 30, 2016
    Messages:
    8
    Likes Received:
    0
    Yes, I forgot to mention this was the first thing I did was to try on another computer was well as another browser.

    Opera, Firefox, and Chrome.

    Regards,
    Steve
     
  4. sfchampeau

    Joined:
    Oct 30, 2016
    Messages:
    8
    Likes Received:
    0
    Also, want to clarify that this is version debian-8.6.0-amd64-netinst-3cx.iso.
     
  5. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Could you please confirm that 3CX Management Console service is running?

    I see you are a linux user, so type this pls
    service 3CXPhoneSystemMC01 status
    or
    top -u phonesystem

    Confirm that Management Console is running.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Can you also post specs of machine?
    Whoever has this problem, post specs CPU Memory and type of disk
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. sfchampeau

    Joined:
    Oct 30, 2016
    Messages:
    8
    Likes Received:
    0
    Nickybrg thanks for the reply.

    Yes, the service is running:
    service 3CXPhoneSystemMC01 status
    ● 3CXPhoneSystemMC01.service - 3CX PhoneSystem 01 Management Console
    Loaded: loaded (/lib/systemd/system/3CXPhoneSystemMC01.service; enabled)
    Active: active (running) since Wed 2016-11-02 21:59:22 PDT; 3min 56s ago
    Main PID: 569 (ManagementConso)
    CGroup: /system.slice/3CXPhoneSystemMC01.service
    └─569 /usr/lib/3cxpbx/ManagementConsoleJS -p /var/lib/3cxpbx/Instance1/Data/Http/webroot

    System is a quad core with 4 gb of memory, 250 SSD hard drive and is running 3xzV15 Debian as a guest operating system on VMworkstation 12.1 with 1 core, 1 gb, and 20 gb of space.

    Now here the interesting thing I just reload the old virtual machine that was giving me troubles, but I renamed the virtual machine from 3cx beta to 3cx beta1 because I'm currently working with a clean copy for testing also note the IP Address changed. The bad copy is now working and I'm able to access via the web console.

    So, I followed the same steps to break it.

    I entered an extension 200 and passcode it failed to login. I then tried to login with my Admin login and I received Server Error. I then cleared my browser chrome as well as I tried Opera to login via my Administrator and I received Server error as well as I stopped virtual machine and restart vmworkstation it still failed to login as Administrator.


    Here is status
    ● 3CXPhoneSystemMC01.service - 3CX PhoneSystem 01 Management Console
    Loaded: loaded (/lib/systemd/system/3CXPhoneSystemMC01.service; enabled)
    Active: active (running) since Wed 2016-11-02 21:59:22 PDT; 18min ago
    Main PID: 569 (ManagementConso)
    CGroup: /system.slice/3CXPhoneSystemMC01.service
    └─569 /usr/lib/3cxpbx/ManagementConsoleJS -p /var/lib/3cxpbx/Instance1/Data/Http/webroot

    Nov 02 21:59:21 kimbatel sudo[707]: phonesystem : TTY=unknown ; PWD=/var/lib/3cxpbx ; USER=root ; COMMAND=/usr/bin/apt-get update -o Dir::Etc::sourcelist=sources.list.d/3cxpbx.l...ist-Cleanup=0
    Nov 02 21:59:21 kimbatel sudo[707]: pam_unix(sudo:session): session opened for user root by (uid=0)
    Nov 02 21:59:22 kimbatel systemd[1]: Started 3CX PhoneSystem 01 Management Console.
    Nov 02 21:59:24 kimbatel sudo[707]: pam_unix(sudo:session): session closed for user root
    Nov 02 22:00:35 kimbatel sudo[785]: phonesystem : TTY=unknown ; PWD=/var/lib/3cxpbx ; USER=root ; COMMAND=/usr/bin/apt-get update -o Dir::Etc::sourcelist=sources.list.d/3cxpbx.l...ist-Cleanup=0
    Nov 02 22:00:35 kimbatel sudo[785]: pam_unix(sudo:session): session opened for user root by (uid=0)
    Nov 02 22:10:59 kimbatel sudo[950]: phonesystem : TTY=unknown ; PWD=/var/lib/3cxpbx ; USER=root ; COMMAND=/usr/bin/apt-get update -o Dir::Etc::sourcelist=sources.list.d/3cxpbx.l...ist-Cleanup=0
    Nov 02 22:10:59 kimbatel sudo[950]: pam_unix(sudo:session): session opened for user root by (uid=0)
    Nov 02 22:12:02 kimbatel sudo[1008]: phonesystem : TTY=unknown ; PWD=/var/lib/3cxpbx ; USER=root ; COMMAND=/usr/bin/apt-get update -o Dir::Etc::sourcelist=sources.list.d/3cxpbx....ist-Cleanup=0
    Nov 02 22:12:02 kimbatel sudo[1008]: pam_unix(sudo:session): session opened for user root by (uid=0)
    Hint: Some lines were ellipsized, use -l to show in full.
     
  8. sfchampeau

    Joined:
    Oct 30, 2016
    Messages:
    8
    Likes Received:
    0
    More info I moved the virtual machine 3cxV15 Debian (running VWworkstation 12.1) to another PC started it up and I was able to login Admin via the webconsole.
     
Thread Status:
Not open for further replies.