V15 SP2 - Desk phone BLF stopped working

Discussion in '3CX Phone System - General' started by pagsinc, Oct 13, 2016.

Thread Status:
Not open for further replies.
  1. pagsinc

    Joined:
    Oct 13, 2016
    Messages:
    9
    Likes Received:
    0
    We have a combination of people on desk phones (Aastra 6730i) and softphones. Everyone has the 3CX Windows app, in either softphone or CTI mode. BLF on the Aastra phones was working fine until I upgraded to SP2 - now it only works on the Windows app. The desk phones seem to be configured right - when I hit a programmed key it calls the appropriate extension configured.

    When I open up the log reader this is a prominent error: " [CM101008]: The '' feature is disabled in currently activated licenseBLF".

    We're currently using the free version, but plan on upgrading to pro soon. Any idea why it worked in SP1, but not in SP2? Can I fix it?
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,416
    Likes Received:
    277
    BLF Status Updates were not part of the free offering in the past if I recall properly - so it is possible it was "accidentally enabled" by the developers in SP1.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jrjohnson

    Joined:
    Oct 4, 2016
    Messages:
    36
    Likes Received:
    2
    I'm having a very similar issue also, but with Yealink phones. We are also looking to move to Pro edition once testing is over. I would like to verify, if at all possible, if this is a free vs pro difference. It seems everything BUT the BLFs are working which won't be a problem if an upgrade to Pro would fix it. If not though, it may delay us from moving forward with this project.

    Any info would be welcome.
     
  4. andreaschr

    Joined:
    Oct 26, 2015
    Messages:
    91
    Likes Received:
    6
  5. waldf

    Joined:
    Nov 17, 2016
    Messages:
    1
    Likes Received:
    0
    Hi, I am on the pro version.
    Since the upgrade to V15 SP3 or maybe SP2 the BLF is no longer working for the Yealink SIP-T48G Phones. Lots of
    "11/17/2016 7:00:47 PM - [CM101008]: The '' feature is disabled in currently activated licenseBLF"
    entries in the activity log.
    How can we rectify that? Regards waldf
     
  6. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Could you please tell us the version number when you go to License Activation Page? What do you see I mean which version?

    Also can you try and perform reactivate of the license? Hit Edit and OK. Restart SIP Server and tell me if the problem still persist?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. hesketh

    Joined:
    Jul 18, 2014
    Messages:
    2
    Likes Received:
    0
    We are having the same issue. Tried reactivating license as mentioned to try above - it didn't help. Looked at all extensions; none have any BLFs set. Event and Activity logs show no other errors or details, even with verbose logging enabled.

    Example:
    12/22/2016 1:59:09 AM - [CM101008]: The '' feature is disabled in currently activated licenseBLF
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,479
    Likes Received:
    466
    Can you please let me know if the BLF's are configured in the management console under each extension?
    Also what type of phones are you using?
    Have you tried using a 3CX client for windows and let us know if that works?
     
  9. hesketh

    Joined:
    Jul 18, 2014
    Messages:
    2
    Likes Received:
    0
    In reply to your message:

    -As mentioned in my original post, there are NO BLFs configured under any of the extensions.

    -The phones being used are Yealink T23Gs running the latest 3cx recommended firmware.

    -(Also - We are not and will not be using 3cx clients for windows. We are only using the physical yealink phones. So, this is not something we can test.)

    As everyone on this thread has mentioned, the issue is 3cx server is throwing the "[CM101008]: The '' feature is disabled in currently activated licenseBLF" error and yet no BLFs appear to be turned on anywhere.

    Any other ideas on how to fix this? The error appears constantly and is filling up on overwriting our log files every day; which means we can't find anything else in our logs when we need to because this error has overwritten the rest of our log history.

    Thanks!! :)
     
  10. mahdi

    Joined:
    Feb 1, 2017
    Messages:
    1
    Likes Received:
    0
    Hi all,
    After upgrating 3cx server from v14 to v15, some functionality like "BLF" , "web conference" and "sms" became unavailable and the 3cx phone client présent this alert "3CX could not establish a connection to the 3CX phone system Web API. As a result, features like contacts and présence information will not be available".

    Can i fix it ?

    Problème connexion API.PNG
     
  11. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,416
    Likes Received:
    277
    You have totally hijacked another thread which is presenting a different error than what you are asking about.
    You do not mention if these devices are local or remote that are having the issue either.
    I recommend you start your own thread.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.