Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

v15SP1 Daylight Saving

Discussion in '3CX Phone System - General' started by jms, Oct 6, 2016.

Thread Status:
Not open for further replies.
  1. jms

    jms

    Joined:
    May 23, 2011
    Messages:
    42
    Likes Received:
    0
    I just got told by my Perth office that the phones are all one hour ahead.

    I had Daylight Saving disabled on v14 before I upgraded, because Perth doesn't observe Daylight Saving Time. The server is displaying the correct time.

    There doesn't appear to be a way to change it via the 3CX web management tool.

    If I look in Parameters in the 3CX web management tool I notice:

    DST=0
    TIME_DST_SAVING_MINUTES=60

    The phones are Yealink T22s. When I check the Time & Date section of the phone web interface I notice Daylight Saving Time is set to Automatic. Surely having a parameter of DST=0 in 3CX should cause it to be provisioned as Disabled?

    I tried changing the TIME_DST_SAVING_MINUTES parameter to 0 and reprovisioning one extension. The Offset value in the phone didn't change.

    So I examined the provisioning templates, and found that yealink.ph.xml applied to the T22, and there was a pair of lines in it like this:

    #Configure the daylight saving time feature; 0-Disabled, 1-Enabled, 2-Automatic (default);
    local_time.summer_time = 2

    I changed local_time.summer_time to 0 and re-provisioned one phone. The Daylight Saving Time value in the phone didn't change.

    I logged on to the phone and manually changed the Daylight Saving Time value to Disabled. I re-provisioned the phone and re-checked it. It hadn't changed.

    I can tell those people who were complaining that you can't select a bunch of extensions and re-provision them in the zero maintenance version 15 that it's a lot slower to log on to each phone's web interface to change DST settings.
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,341
    Likes Received:
    535
    Hi there,

    Unfortunately Yealink has enabled DST in Perth where they should't have. We have contacted them about this and we are waiting for a fix. For now follow the instructions below to solve your issue.

    Open in: C:\ProgramData\3CX\Instance1\Data\Http\Templates\phones
    File: yealink.ph.xml
    Line: 1361

    change local_time.summer_time = 2
    to local_time.summer_time = 0

    Restart the service 3CX Management Console.
    After re-provision one sample yealink phone and let us know if this solves your issue
     
  3. jms

    jms

    Joined:
    May 23, 2011
    Messages:
    42
    Likes Received:
    0
    Thanks Yiannis, that worked.

    I had already made the change in the xml file yesterday, but I didn't re-start the Management Console service..

    Curious as to why this is necessary. Does the service cache the phone provisioning files?
     
Thread Status:
Not open for further replies.