Version 15.5 - Call Pickup *20* not working when CSTA enabled

Discussion in '3CX Phone System - General' started by tsukraw, Jun 21, 2017.

Thread Status:
Not open for further replies.
  1. tsukraw

    tsukraw New Member

    Joined:
    Mar 9, 2012
    Messages:
    190
    Likes Received:
    6
    Wanted to throw this out there and see if anyone else was seeing a similar issue.
    I have a couple installs that use the *20*extension to do call pickup when they hear another extension ringing.

    Since upgrading to Version 15.5 the *20* is not generating the same result it used to. I have had 3 different customers report this issue.

    Here is the scenario
    Extension 10 calls Extension 15
    Extension 15 is not at their desk and extension 20 can hear their phone ringing.
    Extension 20 dials *20*15 (expected result is extension 20 and extension 10 will connect)
    NOTE: All dialing is being done from the physical phones. NOT 3CXphone or WebUI.
    The result that we get is,
    Extension 15 stops ringing.
    Extension 20 shows call connected, but shows *20*15 instead of extension 10 name. Not really connected.
    Extension 10 continues to ring.

    What we have found is this is somehow related to CSTA. In our testing we used Yealink phones (46G) that on 28.81.0.60 firmware also tested on 28.81.0.71 firmware.

    In testing to get around the issue, if we disabled the CSTA Control on the phone dialing *20* the call pickup would work just fine. As soon as we have CSTA Control enabled again on the phone dialing *20* we can no longer pickup calls.

    Anyone else seen this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,473
    Likes Received:
    284
    Hello @tsukraw

    Please try to replicate the issue with default templates and the supported firmware which for these phones is 28.81.0.61. I have tried the same phone with default templates and the supported firmware and could not replicate the issue.
     
Thread Status:
Not open for further replies.