Voice comes in but no voice goes out?

Discussion in '3CX Phone System - General' started by nmadiratta, Nov 27, 2007.

  1. nmadiratta

    Joined:
    Nov 27, 2007
    Messages:
    4
    Likes Received:
    0
    Just wondering if anyone has any suggestions. I'm using 3CX v 3.1 I believe, it is the latest build on the web-site. I am connecting to webcall.ca for my VOIP Provider and everything seems to authenticate okay.

    I can make/receive calls, and I can hear the other person but they cannot hear me. I'm using the 3CX Software Phone, latest version on the web-site. Just wondering if anyone has any ideas?

    I have tested the headset and verified that it works, I can even see the level indicators go up so I know the headset is working. Any ideas? Am I doing something wrong?
     
  2. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    make sure STUN is resolving your IP Address(you can see if theres any error message on server logs). Stun is number 1 cause of audio problems with Voip

    Cheers
     
  3. nmadiratta

    Joined:
    Nov 27, 2007
    Messages:
    4
    Likes Received:
    0
    Ahh okay. I will check in to that when I get home. Is there an STUN I could use?
     
  4. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    The default 3cx uses should be enough, in some cases thoug(i had this problem) i had to go to Voip line configurations and below proxy and registrar i had to input a diferent STUN server to be used... try some of this list http://www.voip-info.org/wiki-STUN

    Cheers
     
  5. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Good evening

    Good evening,

    When you call internally from one internal extension to another can you hear voices both directions?

    Is the extension you are calling from internal or external?

    Have you bound the extension to the media server?

    My thinking is that if you can send and recieve voice when you call another internal extension, there may be a firewall issue such as a port that needs to be opened.

    Take care
     
  6. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
  7. nmadiratta

    Joined:
    Nov 27, 2007
    Messages:
    4
    Likes Received:
    0
    Alright, I appreciate the help guys. I checked my router and had everything except for port 3478, and 9000-9003. I checked the STUN as well and that is resolving correctly in the server log.

    The problem is still there. The weird thing is that when you speak in to the mic you can hear it play back on the headset, so I'm wondering if there may be some weird issue with the 3CX software? Or if my router is sending back incoming packets to me before they can get out of the network?

    Also, I only have one ATA and one fax machine at the moment. I don't have any other extensions, although I will try setting up one after work on my laptop and see if that makes a difference.

    Any other suggestions in the mean time?
     
  8. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Port 3478 must be opened in router for STUN.
    Hope you restarts both router and 3cx after making these changes.. ;)
     
  9. nmadiratta

    Joined:
    Nov 27, 2007
    Messages:
    4
    Likes Received:
    0
    I did open it, and I restarted the router, but I may have forgotten to restart 3CX. I will try this once I get home.
     
  10. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Good afternoon

    Can you talk to other internal extension ok then?

    You can use softphones for the other extensions if you currently only have one adapter.
     

Share This Page