Voice mail Hangs up

Discussion in '3CX Phone System - General' started by jloper, Oct 5, 2010.

Thread Status:
Not open for further replies.
  1. jloper

    Joined:
    Sep 28, 2010
    Messages:
    5
    Likes Received:
    0
    Got my 3CX system working with Vitelity. Inbound and outbound working well. The issue I am having is that when 3CX transfers to Voice mail, it just hangs up with no prompts. The same thing happens if I call from an external phone or from an internal extension. Either way, I just get hung up on.

    Any ideas why a new install of 3CX 9.x would exhibit such behavior?

    John Loper
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,869
    Likes Received:
    304
    You might want to look at the 3CX logs showing one of the calls. If the problem isn't obvious, then post the log here.
     
  3. TotallyVoIP

    Joined:
    Jul 2, 2010
    Messages:
    77
    Likes Received:
    0
    Is this a new install or an upgrade of a working system?
    Are you using a softphone or a desk phone, if desk phone what model.

    we had similar problems with desk phones and depending on the make/model you may need to tweak some settings.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Are you on SP2 of V9?

    I saw some problems with system extensions not starting (or stopping/unregistering themselves). 3cx are aware of this and thought it was fixed, but again we had a problem on our system a few weeks ago when one of the 3cx staff were in tracing a problem. So they packed up our logs and looking into it.

    But if voicemail or other system extensions have stopped then it will hangup.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. jloper

    Joined:
    Sep 28, 2010
    Messages:
    5
    Likes Received:
    0
    How do I view the 3CX Logs? I think this might actually be part of the problem. When I make the call, an event is created in the system Application log as follows:


    The description for Event ID 1309 from source ASP.NET 2.0.50727.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    3005
    An unhandled exception has occurred.
    10/6/2010 11:40:14 PM
    10/7/2010 3:40:14 AM
    8fb1443df34a4d228b712063ff7c4827
    2
    1
    0
    /LM/W3SVC/2/ROOT-2-129308964133786000
    Full
    /
    C:\ProgramData\3CX\Data\Http\Interface\ivr\
    PBX01
    1588
    w3wp.exe
    NT AUTHORITY\SYSTEM
    Exception
    There is no EventLog source named 'ASP.NET 2.0.50727.0'. This module requires .NET Framework 2.0.
    http://localhost:5484/ivr_start.aspx?IVRHandlerFROM=101&IVRHandlerMENU=999&IVRHandlerTO=999&ISID=From_101_To_999_Menu_999_%230%2F8
    /ivr_start.aspx
    127.0.0.1
    False
    NT AUTHORITY\SYSTEM
    3
    NT AUTHORITY\SYSTEM
    False
    at WebMonitor.TCXUnhandledExceptionModule.Init(HttpApplication app)
    at System.Web.HttpApplication.InitModulesCommon()
    at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)
    at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)
    at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)
    at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)


    I checked the HTTP Log files @ C:\inetpub\logs\LogFiles\W3SVC2 and all I found was a single entry as follows:

    2010-10-07 03:40:14 127.0.0.1 GET /ivr_start.aspx IVRHandlerFROM=101&IVRHandlerMENU=999&IVRHandlerTO=999&ISID=From_101_To_999_Menu_999_%230%2F8 5484 - 127.0.0.1 3CXIvrEngine/1.0+libwww/5.3.1 500 0 0 1560

    John Loper
     
  6. jloper

    Joined:
    Sep 28, 2010
    Messages:
    5
    Likes Received:
    0
    OK. I was able to get this working, but I'm not sure the implication of the change I made. I change the web.config [yes, I'm a software developer so I had some idea what I was looking at/for]. I commented out the handler that was throwing the exception.


    <httpModules>
    <!-- JPL: add name="TCXUnhandledExceptionModule" type="WebMonitor.TCXUnhandledExceptionModule" / -->
    </httpModules>

    I restarted the web site. And now the Voicemail IVR and the outside IVR's seem to be working.

    Is there an update to correct this problem?
    I think this should be reported as a bug.

    John Loper
     
  7. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    I dont think you have solved the problem, just hidden it.

    I assume from your post you are using IIS for the web server. Is it 6 or 7 and what else are you hosting in IIS?

    By commenting out that line you have disabled the unhandled exception handler. So we can assume that you initially had a problem which then was unhandled and called your handler which may also have had a problem. You have removed the last problem but not the problem that was calling this handler in the first place.

    Either your install went wrong initially or there is a conflict in your IIS which may have to be manually adjusted.

    We use IIS7 with no problems so I doubt it is a bug in 3cx.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.