Voice Mail Not Saving Message without #

Discussion in '3CX Phone System - General' started by ITWorks, Jun 12, 2007.

  1. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    It seems people who call us and leave voice messages are used to just hanging up the phone when they are done and seem to ignore the message to press the # key when done and 0 to save. They record a long message and then just hang up. The message is lost.

    In a reply by admin to mike_at_softare in January.

     
  2. Costas3CX

    Costas3CX New Member

    Joined:
    Jan 23, 2007
    Messages:
    217
    Likes Received:
    0
    I am not 100% sure what is happening in your case, but from experience I can tell you this.

    When someone calls and leaves a message longer than 2 minutes in the version that you have, it is not saved. In the new version which should be updated within days, the behavior is that after 2 minutes message will be saved. Now from what you describe I can only assume (since i don't have sufficient info) that there is a possibility that your gateway does not terminate the call when people call. So when people call and put down the phone after leaving a message instead of # 0, what happens is that the gateway possibly does not terminate the call, the line remains open, and after 2 minutes voicemail manager rejects the call and doesn't save.

    Can you check if the line remains on, when you close the phone (have someone call in from external number to your gateway)?
    Also can you check calling an internal extension, from an extension within the company and leaving voicemail, and closing the phone to see if the voicemail is saved (without # 0) when putting down the phone?
    what is the brand/model of your gateway?

    I believe that when you dial from extension to extension that this problem will not appear and the message will be saved.
     
  3. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    You are so good!

    That is exactly what is happening. I went back and rechecked the Sipura SPA3000 settings, paying close attention to the PSTN Disconnect Detection settings, but all is per 3CX instructions. I have resorted to:

    Detect PSTN Long Silence: yes
    Detect VoIP Long Silence: yes
    PSTN Long Silence Duration: 30
    VoIP Long Silence Duration: 30

    At least this way the line will eventually hang up.
    Thank you. You have shown me this is not a 3CX problem so now I will concentrate on the Sipura Gateway and the PSTN signaling.
     
  4. Anonymous

    Anonymous Guest

    IT WOrks,

    Focus on your call progress tones. they might be set wrong.

    If any hassles let me know.
     

Share This Page